Slinger - SSI+CGI doesnt work :\

Hi there!

QNX 4.25SE

I have configured slinger like this:

slinger &

Created 3 test pages:

index.html with text
test.shtml with some SSi commands
test.cgi - small cgi script.

Index.html works fine.
test.shtml - show html stuff only and IGNORE SSI commands eg.:
<–#virtual =“index.html”–>

or even:

<–#echo “text” →

Slinger just ignore my SSI commands. Dont know how to run CGI too, what URL should it be - i meam i have tryewd like host_here/cgi-bin/test.cgi

bu it doesnt work.

Any1 could help why slinger works for me with html only ?

You are right that you should access your CGI using the URL host/cgi-bin/test.cgi for your /web/cgi/test.cgi script. What do you get in the browser when you hit this URL?

Can you try to export those HTTP* variables before starting slinger ?
export HTTPD_ROOT_DIR=/web/docs
export HTTPD_ROOT_DOC=index.html
export HTTPD_SCRIPTALIAS=/web/cgi

oh, for SSI, you need to start “slinger” with -s -e options. Do a “use slinger” for details.