Mozilla update


I just installed 6.2, and then got the Mozilla 1.0 package from After I installed the package, Mozilla is still version 0.9.8. I assume that 1.0 is somewhere on my computer, but I can’t find it. What should I do to get it running?

Read this thread
and you will understand your problem more.

You can download and install the tar format mozilla package in the download aread:
then you don’t have to deal with the packaging issues.

Ok, thanks. It’s strange that even the official package from QSSL doesn’t replace the one in the bundle when installed.

There are no packaging issues, it is a Launch menu issue. When you install the QNX mozilla package it will install properly (just as my mozcdm ones do) but they don’t always replace the stock installed version. Installing a package is just as easy (if not easier) then a tarball.

Ok! Is there any way I can make the new package replace the old one?

That is unfortunatly up to the maker of the package.

Using the new installer instead of the old one helped. The old package was replaced. One might think I would have tried that before posting here. Sorry to bother you.

Well, I read the above and downloaded Mozilla-ph-1.2.1. For the first time in my live untarred something. Then tried to run from a terminal 'cause of the menu problems. And I just can’t get it to work. Isn’t there a step by step thingy somewhere ? (If there is I can’t seem to find it)

Any help would be great,


Assuming you downloaded and put the tar file in /home/noc/mozilla-ph-1.2.1-build2-qnx6.tar.gz

as root
cd /
tar zxvf /home/noc/mozilla-ph-1.2.1-build2-qnx6.tar.gz

you can then run it as any user:

if you want, you can just copy the script /opt/openqnx/mozilla-ph-1.2.1/mozilla to a directory that is in your PATH (such as /usr/bin) so that you can just type “mozilla” to start it.