QNX 6.2.1 nc crashed :o(

I ran into a problem with my new QNX install the other day. I was using Mozilla - Firefox to view a website when the system appeared to lock up on me, the cpu monitors in the corner showed both cpu’s frozen, and I wasn’t even able to ssh in or even ping the system. Since I then repeated the crash after a reboot at the same site I’m pretty sure it’s something weird with Mozilla, but I’m wondering what kind of log files are kept by QNX? Where could I start to track this down? Any pointers would be appreciated.

If mozilla core dumped, you could look in /var/dump. Sounds to me like a java issue, i noticed certain sites that are java intensive will do that to moz/firebird, yet will be less cpu intensive while using voyager. I myself havent had the system lock as you have, but ive had mozilla/firebird core dump on me quite a few times on various sites.

p.s. after a forced reboot, its a good idea to run /sbin/chkfsys / as root user to fix any corrupted files.

Good luck.

I am wondering what the overall stability is of the QNX 6.21 system after reading that it only took mozilla to bring it to it’s knees. In a server enviroment it would be important to have the general system (OS) running if and when let’s say one daemon would crash. In turn that would mean that because the general system has not crashed, all your other daemons would still be up and running and there for your other services are still available!

That kind of stability is what I seek in an overall ‘stable’ OS. Is this ‘usually’ the case in QNX and is the mozilla problem a ‘one of a kind’ type of thing?

I would be glad to have some light shed on the matter.


Well, I’m not sure that the lock up was entirely related mozilla, I’ve had some other developments since I posted that indicate my hard drive is on it’s way out. I’m sure some of the other longer standing members here can speak better to it’s stability but from what I’ve seen the OS itself is usually solid.

This lock-up was more a one of a kind thing then…? :slight_smile: Quite glad to hear that.

I just finished downloading QNX 6.21 and hope to try it out on a PI - 133Mhz sometime this week.


I doubt the system locked up. More likely that photon died. If io-graphics goes by-by for whatever reason (normally due to font issues) then the screen will be left in a frozen state, but the rest of the machine is running along just fine.

This seems more like a system-wid lock-up rather than a proton only one, don’t you think???


Not if io-graphics died, that means the entire screen would be frozen in time. The test for a system-wide lockup on a PC is the NumLock test. If hitting numlock doesn’t toggle the LED on the keyboard that generally means things are hosed beyond recovery.

Interesting way to test, Toshiba forgot to supply a num-lock key with my laptop but the same works with Caps lock. I’ve been trying to get RAW callbacks to work, but QNX locks up immediatly when I run my program which has the RAW callbacks, no mouse pointer, SSH, ping, or even caps lock works, so I guess it is indeed hosed. Is there any way to diagnose why this happens? It’s completely replicable, happens every single time.