Integrated Intel Pro/100 VE NIC

Does anyone know if QNX 4.25 is able to support the (integrated) Intel Pro/100 VE NIC? Is there a driver, or a way (through command line options) to get another driver to recognize the card?


This page says “Intel PRO/100 VE” is supported and can be autodetected by “nettrap”. … ttrap.html

Yeah, I saw that… But nettrap is not finding it. And at the bottom of that screen I went to the “Net.*” link to try to find the specific driver I would use and there is not one listed.

I was hoping someone else had needed to do this before with this type of card and possible knew some trick, or maybe some command line switches that make a different Net.* driver work.

Try Net.ether82557 or Net.ether82595. If that doesn’t work run show_pci and look at the vendor and device Id of the card and force them via -D and -V arguments.


I tried those two drivers, but it seems to be freezing up my machine. I tried just starting those drivers, and starting them with the device ID. both froze.

When I type “use Net.ether82557” (or …82595), the -D and -V are not listed, although -D is accepted as an argument and -V is not. also, -i is listed but gives me the error “invalid argument” when I use it with the 82557 driver.

Am I running it wrong? should it be inside netstart (I am trying to start it directly from the prompt right now)? Any more ideas? show_pci finds it with no problem. I am using 4.25B in case that makes a difference.

Here is the output from my show_pci command:

If anyone can give me a hand… I can post the sysinit file if there is the possibility of something in there conflicting with the card. I am guessing I should be able to get this card working since show_pci finds it. Anytime I run the Net.* commands, the whole computer freezes. The Net.ether82595 freezes the computer to the point I have to unplug it because the power switch doesn’t work.

I just upgraded my Net.ether82557 driver from the version that comes with 4.25B to the version that comes with 4.25G. Now nettrap (the 4.25G version) catches the onboard card, and the driver doesn’t crash the system. Everything is working fine using the exact output from nettrap.

I too have a similar problem and would like to use the driver from the G patch. Can you mail me the driver that worked for you as an attachment. My e-mail ID is Thanx.

I downloaded the QNX-4.25 G patch and got the driver running. It works but you have to specify most of the command line options. Another problem that started after installation of patch - G is that my QNX-4 box would not log me in. Had to boot thru a floppy and fix it.