Strange problem with QNX

Ok, I bought a package called AmigaXL and Amithlon. Two different Amiga Emulators on one cd. It came with a Non commercial version of QNX 6.1.0. Amiga XL needs to be installed under QNX.

Well when I first got it, I wiped the Linux dirs from both my 40 gig hd’s. Installed QNX to the first hd and installed Amiga XL in QNX. I had the AmigaXL setup the second hd for Amiga FFS partitions.

Anyway I had no problems when installing QNX, everything worked. Amithlon doesn’t need QNX, as it is supposed to run by just booting off of the cd. But Since I have a Geforce FX-5900 Nvidia card, it doesn’t have the drivers on the cd, so I can’t boot into it yet.

Well I had also picked up Amiga Forever 6, which could run under Linux or Windows. So I cleared everything and installed Windows on the first hd and tried Amiga Forever.

Well, I decided I wanted to try something with Amiga XL again, so I wipe the Windows partitions off, and install QNX 6.1.0, but this time when I get to the first re-boot where I need to set up the screen size, I move the mouse, but no pointer moves. When I finally get past that screen, I get the QNX desktop and the pointer is stuck in the center. I cannot move it.

I did not have this happen the first time I used QNX.

I downloaded the NC 6.2.1 and installed it, and I can move the mouse pointer, but when I try to install the Amiga XL, I get a couple of dependencies warnings, so I do an upgrade via the installer, and then Amiga XL installs with no warnings.

But when I try to run it, I get a screen that says it can’t locate the first program that gets loaded during bootup.

So I can get a install of Amiga XL in 6.2.1, but it won’t run correctly.

And the 6.1.0 that came with it still won’t let the pointer move when I move the mouse.

I don’t understand this at all. How can 6.1.0 work right the first time, but after I try something in Windows, it suddenly can’t find the mouse?

I don’t know if I should try to download the 6.1.0 iso and burn it to a new cdrw and see if that gives me the same problem.

Is your mouse USB or PS/2? Whichever it is, try the other kind if you have it.

When you say ‘first program during bootup’, does it give any other clues as to what the problem is? If you are running AmigaXL by pushing a button, try from the terminal, it may give a more verbose error.

Well the mouse is a USB, plugged into the PS/2 via adapter. But I get the same thing when I plug it into the USB directly. I can’t see running Windows to run Amiga Forever 6.0 for awhile would cause QNX 6.1.0 to not see the mouse.

i even tried 2 different hard drives, still cannot move the mouse pointer under 6.1.0, but can under 6.2.1.

Seems like if I lost the mouse, I wouldn’t get it to work under windows, Linux, QNX 6.2.1, etc, but it does work on those.

Not much, Under QNX 6.2.1 it’ll display an amiga screen and a window that says cannot find C:LoadMonSys. And that’s all it says.

I will need to re-download and burn 6.2.1 as I re-used that cd to burn the downloaded 6.1.0 on.

When I had a working 6.1.0, and I start AmigaXL it loads the Amigaos off of a partition that AmigaXL reads from. /usr/Amiga/dir/SYSTEM (Something like that) and I get a working amiga. And in the S:Startup-Sequence the first command it runs is C:LoadMonSys. Which when using QNX 6.1.0 it works.

But under 6.2.1, the directory is there and all amiga files are there, but when I start AmigaXL, it acts like it cannot find any directory.

Everything in /usr/amiga is the same when I install AmigaXL under QNX 6.1.0 and QNX 6.2.1. But for some reason under 6.2.1 it cannot access anything in the dir.

Apparently 6.1.0 when installed, installed everything that AmigaXL needed as I could go right after the install, to install AmigaXL and be running AmigaOS quick.

But with 6.2.1, I have to run the updates to get AMigaXL to install, and then can’t get past that first command.

You could try out a normal PS/2 mouse, no adaptors or anything.

You might be better off sticking with 6.1, 6.2.1 is a little different to 6.1 and it’s not that surprising it does not work. If the only problem with 6.1 is the mouse, might be better off persevering with that.



I’ll try to see if I can find one.

Most of the ones I find in the stores are always USB with a USB to PS/2 adapter.

I might have one stuck in one of my drawers, I’ll look for it and see if it changes anything.


AmigaXL works fine on 6.2.1, but has one glitch. You need to rename or move the cdrom driver in AmigaXL or it’ll hang. Seems something has changed in 6.2.1 since 6.1.0 regarding cdrom drives. After that it should work fine. As for the mouse issues what brand of usb mouse? I have a cheap compaq infrared mouse using the usb to ps/2 adapter and its fine, but like the post above, try an old ps/2 or serial mouse and you should be good as gold.

Note: after renaming/moving the amigaxl cdrom driver amigaxl wont be able to access the cd drive, but qnx will be able to yet.

I found the solution searching through yahoo’s amiga groups. You may want to do the same for more detailed info on this solution as i’ve long since lost the direct link to the posts.

Cheers. :smiley:

Well, the mouse I have is a Microsoft Trackball optical 1.0 PS2/USB Compatible mouse.

I found a old Microsoft PS2 mouse that came with a system I bought a long time ago, and I still get the same thing with 6.1.0.

Something must have went bad on this MB or something, cause it’s strange that 6.1.0 worked when I first got it, but after trying Windows, then I can’t move the mouse under QNX 6.1.0.

I will have to download and re-burn the 6.2.1 and try that out. I guess I could always flip to the QNX side, copy what I need off of the cd to the home dir and then flip back to AmigaXL to access what I need.

But, after I make the FFS partitions on the 40 Gig HD, I guess I would have to copy the OS-3.9 instal dir to the home dir so I could install the OS3.9 on it.

WooHoo. I re-downloaded the iso for 6.2.1 and burned it, and installed it and the updates.

I then installed AmigaXL and went into /usr/amiga/System/Devs/DOSDrivers and moved both CD0 and to a separate dir and then clicked on AmigaXL and it booted up like it used to on QNX 6.1.0!

That tip worked!!! THANKS!!!

I also found that I can still access cd’s in the AmigaXL by clicking on the Root icon and show all and go to fs/CD0 and I get the icons for the porgrams on the AmigaXL cd and I was able to run the AmigaXL update to update the AmigaXL and use HDToolbox to set up some partitions on the 2nd 40 gig HD.

I’ve noticed a big difference. Under QNX 6.1.0, viewing web pages either with Voyager under QNX or AWeb under Amiga emulation was a bit slow. But under 6.2.1, web pages come up much faster under Voyager and Aweb.

And when I had it working under QNX 6.1.0 and I was formatting the Amiga FFS partition I set up on the second drive, it took a while and if I moved the mouse, the pointer would hang and then move a bit and hang and move a bit.

But under QNX 6.2.1, I formatted the same size partition alot faster and I could move the mouse pointer freely with no slowdown or hanging. I guess under 6.2.1, the formatting doesn’t hog the cpu like under 6.1.0?

I just got done installing AmigaOS 3.9 to the partition on the second HD and am getting ready to set up some more stuff.

I appreciate the help. Thanks again.

Wonder if that’s going to work with 6.3 .

I don’t know. It’ll be interesting to try. :stuck_out_tongue:

Well, even though I can access a cd through root:fs/cd0 under AmigaXL, when I try to install the Boing Bag 3.9-2, it gets to the part asking me to insert the OS 3.9 or AmigaXL disk. I insert it, but since there is no CD0 driver loaded, it can’t see the disk.

I even tried assigning CD0: to root:fs/cd0. But it still cannot do it. I’m going back to the yahoo groups, cause that guy mentioned a way to enter something that might help, but I don’t know.

Apparently there is something off the cd it reads off of it to unlock the .lha file. I tried unlha it myself, but it asks for a password, so something on the cd is used as a password, but no idea what.

Sorry to bring an old topic up again, but is the thing with the cdrom thing the same in 6.3 as it is with 6.2.1? Or did they go back to the way 6.1 did it?

What I mean is, under 6.2.1, I had to move AmigaXL’s CD0 out so it would boot. Would I still have to do that under 6.3?

I’m getting ready to download it now. I hope that maybe it’ll run like on 6.1 so I’ll have access to the cd easier.

I doubt it. QNX’s cdrom drivers changed in 6.2.1 and up. I’m assuming its because 6.2.1 was when they implemented cd burning capability. So more than likely you will have to do the same thing to get amigaxl working on 6.3.0 also.

Kind of thought that was going to be the way it was. I liked how much snappier AmigaXL ran on 6.2.1, but not being able to update the Amiga OS to Boing Bag 3.9-2 is a pain. Cause during the install, it needs to read some things off of the cd.

I noticed that 6.3.0 is only availabe as a 30 day trial only, and not like 6.1 and 6.2.1 where you could choose either the 30 day trial, or the cut down free version.

Just where do they hide the price for it? I looked all over and could not find anything that mentioned how much 6.3.0 would be after the 30-day trial.

I imagine it’ll be too high for me to afford, but would like to know out of curiosity.

Thanks for the reply. I was hoping that maybe they would find a way to make it compatible to the way 6.1.0 was. But if I decide to try the 30-day trial version, I’ll see if that trick works on it.

As far as i know, after the 30 day trial ends all you lose is some dev tools. Basically the 6.3 download is a “full” QNX6.3 PE which you would normally have to pay for, but after the 30 days the PE parts are disabled and you end up with a NC version of 6.3.

I’m not sure it would work. But have you tried moving the CD0 driver back after amigaxl boots? Possible it would read the cd after the OS is running. I havent tried it, no longer have amigaxl installed.

Also i dont think qssl is worried about amigaxl compatability. It should be the amigaxl people who update amigaxl to be compatable with newer qnx releases. The people who created amigaxl have had numerous emails regarding the cdrom driver issue and they havent done anything about it. So much for customer support.

Cheers :smiley:

Cool. Well I may give it a try and see. Although I just finally got AMithlon set up and got sound as well. So I’ll have to see about trying qnx 6.3.

Yeah I did try to double click on the cd0 for amigaxl, and then everything just went nuts. Couldn’t do much of anything until a reboot.

Yeah, H&P and the authors of AmigaXL don’t seem to support it at all anymore.

Ok, I went ahead and downloaded QNX 6.3.0 and burned it, and removed my working Amithlon setup, which luckily I now know what I need to get it up and running again.

I have QNX 6.3 installed, and now when I try to install AmigaXL, I get this dependency error. It needs to be installed before it will allow me to install AmigaXL.

I know under 6.2.1, all I had to do was put the 6.2.1 cd in and run Install and there were some updates that when I installed them, AmigaXL was able to install. But 6.3.0 cd doesn’t have anything on it as I’ve tried the search for cd repositories and get nothing.

And since I was short on CDRW’s I ended up erasing the cd that had 6.2.1 to put 6.3.0 on it, so I don’t have a 6.2.1 to put in.

There is the web repository, but I didn’t find any called libstdc++, and I would have no idea if it is inside one of the ones in the web repository or not. There is too many in the list, how would I be able to find the right one?

I’m hoping to find a solution to this, as I’ll either have to re-download the 6.2.1 ISO and re-burn it, or just re-setup Amithlon.

Any idea if there is a package that contains libstdc++ in the 3rd party 6.2.1 software repository?


If you look in /lib you will find a file there. Try making a sym link to that. eg: ln -s /lib/