Any way to set NumLock to ON at boot?

Is there any way to edit the .profile or sysinit.1 or any other file to set NumLock to ON at bootup? Setting it to ON in the BIOS doesn’t work. Using QNX 4.25.

My guess is that the keaboard sets the NumLock to OFF when it is reseted by the Input driver.

Try running inputtrap trap which will create /etc/config/trap/input.NODE
and then add -R option to the kdb driver in the input.NODE file, eg: “kbd -R fd -d/dev/kbd”
This will disable keaboard reset on driver init, which may, aside other things, preserve NumLock status.

Whenever I run inputtrap trap it gives me Command must be query, start or update. And input.NODE is not created.

oops, sorry

run only inputtrap > /etc/config/trap/input.NODE where replace “NODE” with the node number of the machine (eg: input.1), then add the -R option in there

The -R was already there when I went to edit it. Also, even though USB is enabled in the BIOS, I have to use a PS2 adapter for my mouse. Any ideas there?

This is what was there:

kbd -R fd -d/dev/kbd ps2 -r kb -2