Problem with Sylpheed.

I installed sylpheed for qnx a couple of days ago but i cant manage to make it to work.
These are the errors that it encounters when it tries to start.
Are there any missing librarys or whats wrong?


unknown symbol: jpeg_resync_to_restart
unknown symbol: png_set_progressive_read_fn
unknown symbol: jpeg_read_scanlines
unknown symbol: png_set_strip_16
unknown symbol: png_create_read_struct
unknown symbol: png_set_interlace_handling
unknown symbol: TIFFReadRGBAImage
unknown symbol: png_set_gray_to_rgb
unknown symbol: _TIFFmalloc
unknown symbol: png_get_channels
unknown symbol: png_process_data
unknown symbol: jpeg_start_decompress
unknown symbol: png_get_progressive_ptr
unknown symbol: _TIFFfree
unknown symbol: png_get_valid
unknown symbol: jpeg_destroy_decompress
unknown symbol: jpeg_std_error
unknown symbol: jpeg_CreateDecompress
unknown symbol: TIFFFdOpen
unknown symbol: png_get_error_ptr
unknown symbol: TIFFClose
unknown symbol: png_set_expand
unknown symbol: jpeg_read_header
unknown symbol: png_get_IHDR
unknown symbol: jpeg_finish_decompress
unknown symbol: jpeg_stdio_src
unknown symbol: png_read_info
unknown symbol: png_destroy_read_struct
unknown symbol: png_read_update_info
unknown symbol: png_read_image
unknown symbol: png_create_info_struct
unknown symbol: png_progressive_combine_row
unknown symbol: TIFFGetField
unknown symbol: png_init_io
Could not resolve all symbols

Sylpheed qpr at: … lic.qpr.gz

Hmmm… ive installed it on 2 different box’s with no problems. Judging from the errors you got, it looks like you are missing libjpeg, libpng and libtiff which can be found on the 3rd party cd.

It was my first thought too…
Well,libpng and libtiff are installed and reinstalled a couple of times. by now.
And they reside in /usr/lib/
As well as a dozen versions of libpng
Except for libpng.a which (as usually) was broken.
and finally, libtiff.a and
They also resides in the path:

Any other ideas on whats wrong?

The only other thing i can think of is… i built sylpheed after upgrading to the new/updated packages from … so its using the new glib/gtk/iconv/libpng etc.
Otherwise i dont know what to say at this point,sorry. Anybody having the same problem? The more feedback i get will help me fix the problem ( if it actually is the package at fault )

Thats seeems like a reasonable explanation, i will download the new ones and try it…
Besides that, Thanks for all the porrtings you have made :slight_smile:
I have tried to compile a lot of stuff but it usually failes for me and unfourtanely i am not skilled enough to make it work, yet…

By the way, it seems like gFTP has a packetflaw, it will exit with the following error.


GLib-WARNING **: getpwuid_r(): failed due to: No such user 0.
gFTP Error: Cannot find master config file /usr/local/share/gftp/gftprc
Did you do a make install?

Just following up… after grabbing the new packages did everything work ok? If not i rebuilt sylpheed once more and uploaded a new build.
By the way thanks for the info on gftp… it was either me or packager that goofed up ( i’ll just blame packager :smiley: ) …a new build is now uploaded and should work fine now.

Regarding sylpheed, i have a 33k6 modem so i decided to wait for the 6.2.1.CD , because it was a little too much to download.
But gFTP didnt place the config file in the right place this time either, so i moved it from /usr/share/gftp to /usr/local/share/gftp and then it worked just fine :slight_smile:
But i blame my installation, it is a bit strange…