Problem installing 6.3


Today I was trying to install 6.3 on our flash boot rig (a rig we use to burn QNX images to San Disks. It consists of an Intel MB with a 850 Mhz processor, CD-Rom, 256 Megs of Ram, 19 Gig Hd and attachments to burn images to San Disks).

This rig had 6.21 installed successfully on the HD. I went in and used Fdisk to delete the QNX partition (The whole HD was 1 QNX partition)/ I then placed the QNX 6.3 CD into the CD-Rom drive and re-booted.

The first strange thing I noted is that after booting from the CD and finding the Eide devices it declared there was no place to install a QNX partition to. This forced me to use the space bar to get to the boot options to select F10 to force an installation to a drive (any idea why since I already deleted the previous QNX HD partition?).

After using F10 to force an installation I went through the rest of the proceduce to install the O/S. I got past selecting which drive I wanted (the HD and not the San disk), entering the serial number and telling QNX to use the whole HD to install and to use the QNX boot loader I get to the following screen:

Restarting driver and mounting filesystem…
Executing devb-eide blk auto=partition,noatime

path=0 - Intel 82371AB
target=0 lun=0 Direct-Access(0) - Maxtor 4k020H1 Rev:A08
path=1 - Intel 82371AB
target=0 lun=0 CD-Rom(s)-QSI CD-Rom Scr-242 Rev:CXAC
target=1 lun=0 Direct-Access(0) - Sandisk SDCFB-25 Rev:Vdg

Unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase.

Partition Installation Aborted!

Please remove installation medium, then reboot your machine.

At this point everything is frozen and all I can do is re-boot and retry the process with the same result (at least 15 times). I tried telling the installer to use the default boot-loader and the QNX boot loader with no success. I put back in my 6.21 CD and was able to go thru the same process and install successfully. So I know the HD and CD-Rom are working. I then checked my 6.3 CD and there is indeed a boot/fs/qnxbase.qfs file so it’s not a problem of the file not being there (tho the file itself could be corrupt I suppose).

Anyone have any ideas (beyond the possibility of a bad CD burn)?


P.S. Going thru this whole process over and over has made me realize how much I hate entering the serial number at the start of installation for 6.3 as opposed to afterward for 6.21 :frowning:


OK. I spent some more time on this today. First I burned a second CD and tested installing with it to see the same errors as I got with the first CD.

Then time I noticed there is an F6 to turn on a LOT of debugging information for the whole install process. So I selected that instead of F10. Then a massive amount of stuff spews to the screen as it detects my hard disks but at least then I no longer need to select F10 as F6 seems to allow Dev.eide to find my Harddrives.

I was hoping that the delay of spewing info to the screen would help in the actual install process where I get the error that stops me from proceeding. However that was not the case and I still got the error :frowning:

But the extra gobs of debug info reveal some more information. It always seems to stop at the same point (at least as far as I can tell from the hundreds and hundreds of lines of debug info that scrolls by). At that point what I see is something like (going from memory here) over and over:

scsi_interpret sense - error 70, sense 4, asc=8, asg=3

which is strange since I have an eide machine. Anyway on the final line I see an error from cp that ends with (28676, 256) which I guess means it retried 256 times and failed.

Since the debug info allowed me to get further in the process (it obviously died while copying files instead of trying to find the boot image) I made a guess that perhaps this non-standard machine with an older CD-Rom was timing out in someway that 6.3 was sensitive to.

Then I decided to remove the HD (a pain in the ass) from the bootrig and put it in a regular desktop PC. I inserted the 6.3 CD, re-booted and it came up and installed the first time without a single hiccup.

So I’m up and running fine now on the boot rig with 6.3 (well, I have compiling problems with the new complier but that’s a different issue). It definitely appears the 6.3 is extra sensitive to the hardware it’s being installed on. Maybe there can be some kind of option added to increase the retries for hardware that’s older or slightly flaky.