Why can't I Qtalk?

Thanks to all who have helped me iron out QNX 4.25 probs thus far, but I’ve got another one… imagine that.

When I type “qtalk” and then hit enter, I get “Using modem //1/dev/ser1”, but then when I start to type “atdt”, it doesn’t let me. It won’t echo any characters at all to the screen and I have to hit ctrl+a to get out of it. What am I doing wrong?

What type of modem do you have? (QNX doesn’t support Wintel modems)
Is it connected to COM1?

It’s an internal PCI modem, so how would I need to configure it? And it’s not a Wintel.

It wouldn’t be located at COM1 (io port 3f8, irq 4) so you will have to figure out where it is located. If it is pci, it should show up with the ‘show_pci’ utility. You can then restart Dev.ser with the appropriate io port and irq.


The only PCI cards I have installed are a WinTV Tuner Card, a pci modem, and a pci ethernet card. Here are the classes I get when I run show_pci:

Class = Display (VGA)
Class = Mass Storage (IDE)
Class = Mass Storage (IDE)
Class = Multimedia (Audio)
Class = Multimedia (Video)
Class = Network (Ethernet)

Which one is my modem???

Rick, do you happen to use an Instant Messaging client so I can ask you a couple of questions a little quicker?


Try clicking “Live QNX Support” on the left, and ask for rick :slight_smile:

you may want “show_pci -vvv” to make the output more verbose.

Damn, that would be nice!

Oh, it’s definitely verbose now, but it didn’t help me discover which one is the modem. It gave me all kinds of info, but none of it made much sense. What am I looking for?

How about this, guys. Can you give me the make and model of both an internal pci modem and a pci ethernet card that WILL DEFINITELY work with QNX 4.25 with little-to-no manual configuration (or ones that you know how to configure)? I’m tired of messing with it, and I’m sure you guys are tired of answering my questions every day. I went out and bought one of those $15 “Network Everywhere” ethernet cards from Wal-Mart, and of course, it isn’t detecting it. Whenever I run /bin/nettrap query, it just returns:

Net &
slay Net

Thanks, guys.

Unless of course you can figure it out from this (I’m assuming I pulled the right info out of show_pci -v):

[u]Internal PCI Modem (non-winModem)[/u]

Vendor ID = 14f1h,
Device ID = 2702h,
PCI index = 0h
Class Code = 078000h Communication (Other 128) ProgIF=0
Revision ID = 1h
Bus number = 1
Device number = 2
Function num = 0
Status Reg = 290h
Command Reg = 107h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 40h
Cache Line Size = 0h
Base Address = MEM@fe9f0000h,32bit length 65536 IO@ddb8h length 8 bytes
Subsystem Vendor ID = 1028h
Subsystem ID = 8d88h
Max Lat = 0ns
Min Gnt = 0ns
PCI Int Pin = 1
PCI Int Pin = INT A
Interrupt line = 3

[u]PCI Ethernet Card[/u]

Vendor ID = 1317h,
Device ID = 985h,
PCI index = 0h
Class Code = 020000h Network (Ethernet) ProgIF=0
Revision ID = 11h
Bus number = 1
Device number = 1
Function num = 0
Status Reg = 290h
Command Reg = 117h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 40h
Cache Line Size = 10h un-cacheable
Base Address = IO@de00h length 256 bytes MEM@fe9eec00h,32bit length 1024
Subsystem Vendor ID = 1317h
Subsystem ID = 570h
Expansion ROM = fea00000h length 131072 disabled
Max Lat = 128ns
Min Gnt = 64ns
PCI Int Pin = 1
PCI Int Pin = INT A
Interrupt line = 5

slay Dev.ser
Dev.ser ddb8,3 &

and see if that works…


Well, I ran slay Dev.ser and I got: Unable to find process “Dev.ser”.
So, I then ran Dev.ser ddb8,3 & and I got “Done…”

But then when I do nettrap query, I still just get “slay Net”, so I’m assuming it didn’t work.

Actually, at this point, I’d just like to get my modem working. I’ve ordered an Intel Pro/100 S NIC card just like I use at work so I won’t have to worry about configuring it. I just can’t get the modem working. How can I verify that the modem is actually configured correctly? Is there a modem command similar to nettrap query?

Maybe you are running Dev32.ser instead? Post the “sin” output.

Yes, I am, Dev32.ser.

Then why are you trying to slay Dev.ser?

PCI network card is from ADMtek (info obtained from admtek.com.tw/) but it timeouted. I have never heard of this company before.

As for the modem according to the PCI database it talks about 10/100 ethernet which is strange. Get a US Robotic and you should be fine.

You post suggested that slaying/restarting Dev* should have an affect the detection of the network card. If that is what you beleive I recommend you do some reading on Dev and Net.