File Manager doesn't work?

When try to open a directory which has more than 20000 files , I have to wait at least 4 minutes. Then I select 5000 files and press “Ctrl + X”, and what will happen? The File Manager disapear! After that I try again and again to open it without result. My File Manager now doesn’t work. How should I get it run?

Thx for your help!

Now I try to invoke file manager by inputting command in terminal:pfm
And I’m still disapointed by the result:Memory fault(core dumped).
Can anyone tell me what’s wrong with it?

Try, rm -vR /tmp/*
If that’s no good then start deleting files in ~/.ph/pfm

thx for your help. Unfortunately, pfm still can’t work after that way and the error keeps same.

How about, chkfsys /

Thx for your help. Sorry to comment that I’ve also tried chksys before other attempts.

really scratching now … pkgctl -r /usr/photon/bin/pfm

thx a lot, you’re so kindly to help me once again.
I run this command with the result:
[/usr/photon/bin/pfm]has been recovered.Check contents.
Again , run pfm from terminal:
Memory Fault(core dumped)
Why application of QNX are so fragile? Now ,I have to install another file manager(The third party program:MQC).

Maybe could you also help me the question I posted which is about the strange problem of qde.I either can’t get the way out.
All projects under qde’s navigator can’t show just after a stack error occured.If I create a new project and hide it, I also can’t see it again in Navigator. So, where can I find those project in qde’s navigator, really a question.

Prolly a good idea. pfm doesn’t have a great track record.

I don’t know any QDE. Phab maybe?

Sorry, qde is QNX IDE(Lauch → Development → Integrated Development Environment (IDE)). My QNX version is 6.2.1PE

You certainly seem to be good at picking them. pfm has never been a mainstream kinda app, and certainly working with 20,000 files seems a bit extreme in any case. Take a look in ~/.ph/pfm and see what is there. Or better yet, just remove the directory and start over - I assume it created some file which has bad data in it.

qde is still a very immature product. It is getting a little more usable in QNX 6.3, but even then I would only use it for java development (where it is more mature).

Hopefully cdm will comment next time he is here, as he knows the ide better than anyone I think.


thx! I have tried all methods above without success. And I could’t find any useful info by using “coreinfo /var/dumps/pfm.core.”(when use coreinfo, there’s little difference between all .core files?) So I try to use mqc file browser and find the pfm.core keep same after all operations above:those files which caused failure are still there in pfm.core!

As for qde,I’ve found that the project navigator is closed for stack error, so I open it and all be OK. Thx for your help!

Maybe try this on pfm.

  1. rm -rf ~/.ph/pfm
  2. cd /
  3. /usr/photon/bin/pfm

Is it fault right away? Or is it only fault until you go into certain directory?
Is all your filename ASCII ?

I’ve tried again.Fault is right away(no gui at all).Fails again:Memory fault(core dumped).I log in as root, and the filenames under /root are all ASCII.
The problem is no matter after which way I try to recover it, the content of core file keeps unchanged: it includes the filenames when it crashed. I doubt maybe pfm call some other programs which keeps the record. So it’s not completely right to only recover pfm from packages?

OK now. I changed /usr to /user and reboot QNX. To my surprise, QNX setup a new /usr directory with all subdirectory and files! And pfm also works right!
Can you tell me why?

You are running pre 6.3 right? The magic comes from fs-pkg. And it’s a good thing otherwise your setup would have been hosed. /usr is a system directory removing it can have devastaging effect…

It does imply tho, that the bad data was in the /usr (now /user) tree. It might be interesting to look at that directory tree and try to see what was causing the problem.