How can I disable DMA on boot by default?

I am booting to a Compact Flash card, and can’t use DMA. I can boot by pressing Esc for .altboot, but how do I make this permanent?

just cp .altboot to .boot

I copied /.altboot to /.boot but nothing changed. I still have to hit ESC. Are these the wrong files?

Nope. All hitting esc does is cause the loader to use /.altboot rather than /.boot. If you copied them over, then it “should” work.

Confirm they are now the same file:

cksum /.*boot


cksum /.*boot

3168122644 727052 /.altboot
3168122644 727052 /.boot

When I don’t type ESC I get .altboot…S

that’s interesting. this message means
/.boot was read, but it doesn’t look like a valid image (lacks STARTUP_HDR_SIGNATURE) . Given that the cksum is the same between .altboot and .boot, I don’t know why the Alt boot works fine. Something must be screwed up…

Any ideas? Are there any other differences between booting with .altboot besides the boot image?

Try disabling UDMA in the bios settings. And other settings too, Eg: PnP OS.

Try running a cksum over your install CDROM, it should give 82346462 549060608.

I checked what you said and everything is ok. But I don’t think those could have been the problem because it installed file since it works fine when I choose .altboot.

I have a pc-104 with a compact flash, and I did:

cp /.boot /.old_boot
cp /.altboot /.old_altboot
cp /.old_boot /.altboot
cp /.old_altboot /.boot

And it does work.

One question, Isn’t it possible to enable DMA booting to a Compact Flash?