My LAN connection doesn't work


I’m running QNX 6.2.1A in an Intel Pentium IV and my network adapter is an Intel 82562.

I’ve used eepro100 driver in Windows XP and Linux Debian, but I can’t find this driver for QNX.

When I run the “pci” command, it appears the network adapter, but it’s unknown. It must appear the en0 interface in any place, but doesn’t.

Any idea? Thank you very much for your attention!

What is the block from the output of the pci command?

First of all, thank you for your reply.

The output of the pci command is in the attached file “pcifile”. Bye!

If you use eepro100 on Linux, it should be “speedo” on QNX. try

slay io-net
io-net -dspeedo -ptcpip &
ifconfig -a
and see if ‘en0’ is detected.

Hello! I’ve done the steps you said me, but when I run:

io-net -dspeedo -ptcpip

the output is: unable to init dll devn-speedo: No such device.

I tried with other drivers such as ne2000 and tulip. In theese cases, no output was displayed, but the result was the same when I run ifconfig -a (you can see it in the attached file ifconfig.tar).

I don’t know what to do. Thank you for your reply and bye!

If that doesn’t work, check “pci -v” to find out DID (Device ID) and VID (Vendor ID) and hardcode that in the io-net command line. Check this thread:

Hello! Now my ethernet interface en0 appears, and I can do a ping to the gateway without any problem.

But when I try to connect to the Internet, a DNS failure happens: unable to find a IP for the given hostname.

I put my IP in the interface configuration tab. My files /etc/hosts & /etc/networks are attached (conf.tar). I’ve tried to configure the network in a similar way to Linux.

I’m sorry, but I’m new in QNX.

If you are trying to do it similiar to Linux, you should have the DNS server IPs in your /etc/resolv.conf, can you check if that is the case?

Yes, that’s OK! But I don’t know why, it’s works fine now. Thank you very much!