autoconf on 6.3

It worked fine for me on 6.2.1 - on 6.3 however, it tells me it can’t find autom4ke even though it is there…

I noticed file conflicts reported by the installer which I did not see on 6.2.1 when installing the same packages. (it seems to report conflicts left and right).

I have installed 6.3 twice to be sure, I get the same result.

Is this a known issue? Am I missing something simple?

My goal is to compile apache 2.0.50 and PHP 5.0.0 like mikep has done here: , which I did install and get working only to find he hadn’t compiled PHP with mysql, which I require…

(I can get MySQl 4.0.18 running no problem with the supplied binaries from MySQL)

Also, when I attempted to compile apache 2.0.50 on 6.2.1 I could only do so successfully by compiling static modules and disabling mime-magic as mike describes he did as well. (instead he fixed the issue with mime-magic and supposedly a fixed libtool?) What I’m getting at here is how can I get apache to compile with shared modules like he has done - where is this fixed libtool - anybody know? (the current one dumps linked shared modules with the error “od: illegal parameter --x”)

But before I get back to those questions I need to know why autoconf seems broken on 6.3, should I just go back to 6.2.1? Or is there a fix for autoconf on 6.3 or have I missed something?

Nobody else has seen this problem? Does anybody have GNU autoconf 2.57 working on QNX 6.3.0? Have I asked this question in the wrong place? (Should I be asking in the porting forum?) Is this a dumb question? Should I just be re-writing configure scripts manually?

Not quite sure about your autoconf problem, but if you want to compile with shared libs you will need to download the latest libtool source and compile it.(the qnx package of libtool is outdated) It builds w/no problems out of the tarball. Then run ./configure on apache. After configure completes, edit libtool in apache src and change the line that says deplibs_check_method="" to deplibs_check_method=“pass_all”. This should build the shared libs after running make.

Cheers. :smiley:

Thanks for the tip on libtool, much appreciated. I’ll give it a whirl.
Hopefully I can figure out the cause of the autoconf issue, or workaround it.

Well, I used libtool 1.5.6 and made the change you suggested (and mikeP’s edit to mime_magic) and it did not produce any .so files in the modules directory. (just .a and .la files). Same as before (on QNX 6.2.1 with libtool 1.4.3).

Throughout the compile, libtool still generates:
“od: illegal option --x” everytime it is called.

I’ll try installing the latest m4 and autoconf instead of the packages on the online repository…

nope… m4 1.4.1 won’t compile as is… complains of no /sys/signal.h file…

I edited m4.c to point to the location of signal.h on QNX 6.3… and it makes…

now autoconf 2.59’s make fails under …/…/tests/autom4te[18]: syntax error: ‘if’ unmatched

  • got autoconf 2.59 to compile by removing the if statment to test for unset, leaving only as_unset=false on line 21

Solved my original problem, autoconf 2.59 seems to work with m4 1.4.1 with the “fixes” above on QNX 6.3.0…

the apache configure script seems to still think that libtool cannot build shared libraries however… I’m trying again with the new m4 and I’ll edit the libtool in the apache source as suggested again…

I tried a few more things in the apache libtool script:

in addition to changing deplibs_check_method from “unknown” to “pass_all”

I changed build_libtool_libs from no to yes
and build_old_libs from yes to no

hmmm… is build_libtool_need_lc=yes the culprit for the “od: illegal option --x” error? ->nope

no joy from any of these changes…

hah! though gcc 3.3.1 is installed, 2.95.3 is being used…
The inclusion of gcc 3.3.1 is partly why I moved up from
QNX 6.2.1 to 6.3.0, why is QNX 6.3.0 still using gcc 2.95.3?

Guess I’ll see if I can get gcc 3.4.0 going…

well, I waited a long time to find out that gcc 3.4.0’s make fails with an undefined error somewhere in the middle of the java stuff… :imp:

-That’s if I run autoconf on it first, if I run configure as is for gcc 3.4.0
the make dies on conflicting types for ‘wchar_t’ in /usr/include/stdlib.h:46 due to a previous declaration of ‘wchar_t’ in the gcc source stddef.h:325
I’ll try fixing this later today…

nope, gcc 3.4.0 won’t compile with the extra declaration of wchar_t removed for stdef.h, the make is chock full of warnings.

Is anybody using the bundled gcc 3.3.1 in QNX 6.3? If so, how do you get it to work?

QNX 6.3 supports multiple version/target of gcc.
Looks like 2.95 is the default.
Run “qcc -V” to see the whole list.

BTW, this brings a good question: once your evaluation of QNX expires, and you can’t use qcc anymore, you won’t be able to use gcc 3.x no more.

Ah, thanks for the tip, I thought just the IDE stuff expired… I guess I should stick with trying to get things to work with gcc 2.95.3.

whoah, wait, if I get you right then I won’t be able to use 2.95.3 either?

Perhaps I should go back to 6.2.1… is there a full list somewhere of what features expire?

Well, I’ve decided I’m not up to re-writing all the concerned scripts in the apache source to call qcc instead of gcc, and modify all the parameters appropriately. I’d write a webserver for QNXc++ capable of running php from scratch If I were up for that much work on this.

I’m just going to build one honking huge executable with all the static modules including php with mysql. I’m almost there but have hit a bug in php concerning alphasort on QNX that has recurred after being fixed in php 4.3.3.

I guess I’ll search the forums here regarding my question about exactly what features of QNX 6.3 expire, the info must be somewhere…

I got php 5.0.0 and apache 2.0.50 compiled and running well by compiling the works statically with php as a cgi. I may look into producing an installer(s) (when I figure out how) for all the required stuff unless someone puts out a shared module version of the newer apache and php soon.

The compile still produced the “od: illegal option --x” throughout, but everything seems to work just fine.

What makes me happy about this is I got it compiled wih the mysql 4.0.18 client library from the mysql binary distribution for QNX 6.2.1 (which I’m running on 6.3 though…). I haven’t tested SSL yet. Now I just need to figure out what will expire and will my apache-php still work when 6.3 components expire.

Only hitch (as I’m new to running php as a cgi, ;) yes , i know all the issues and my application is for fun anyway…) is that all my php scripts show the line I have to place at the beginning to point to the cgi interpreter: “#!/usr/local/bin/php \n” but a script that only calls phpinfo() does not show it, any ideas?

edit:worked it out - the line pointing to php does not need to be in included php scripts as they are not actually executed , just included.

noc - you can just invoke the fully qualified gcc front end…


…for example. If you look, gcc is just a symlink.