qnx 6.2.1 networking problem

I am not sure why qnx 6.2.1 cannot detect my network card and get it work.

Here is output from “nicinfo”
nicinfo: Could not open: /dev/io-net/en0 (no such file or directo

output from “pci”
Class = Network (Ethernet)
Vendor ID = 1186h, D-link System Inc
Device ID = 1300h, DEF-530TX+ Fast Ethernet Adapter
PCI index = 0h
PCI IO Address = d800h enabled
PCI Mem Address = feaffc00h enabled
PCI Int Pin = INT A
Interrupt line = 3

output from “slay io-net ; io-net -drtl -ptcpip; ifconfig en0;”:
ifconfig: SIOCGIFFLAGS en0: No such device or address.

how to resolve such a problem.

thank you,


I ran into something similar with an intel on-board ethernet recently. here’s what I did.

pci -v

take note of your device id and vendor id(the hex)
the form of the command is:

io-net -d did=0x,vid=0x,verbose -p tcpip

for an example: Intel: Deviceid = 103ah, vendorid = 8086h

#io-net slay
#io-net -d speedo did=0x103A,vid=0x8086,verbose -p tcpip

granted this was for intel, but it should be pretty similar, main thing I’m not sure about is the speedo, but good luck!

thanks for your suggestion. I can also setup IP address. it works pretty well.
the problem is that after rebooting, everything set up is gone. How to keep the settings?
Thanks again.

I also can’t assure you that this will work, but here’s an idea. If you don’t already have an “rc.local” file in your /etc/rc.d directory, you can make one using your favorite text editor and just drop the appropriate io-net command in it. One thing to make sure of before reboot is to make sure all groups have execution privledges on the file…

I haven’t tested that, but it seems like it should work.

thanks. I aslo noticed that I need to put netmanager in rc.local right after io-net command, however, it seems that netmanager in rc.local is useless. I have to type manuall after rebooting to pick up net.cfg file. I even tried “waitfor /dev/socket” or “sleep 8” before running netmanager. it is not effective. Any ideas why netmanager not working in rc.local? Thanks.

QNX 6.2.1 has an issue with network support until the full installation is completed. This is peculiar to 6.2.1 only.

eg: openqnx.com/modules.php?op=m … %20install

thanks. so you recommend to install x86 Momentics packages to get the networking work. I checked CD directory rep621, but cannot find
a package, also, I tried “Installer” from GUI, and cannot find such a package to install. Any suggestions?

Right now, I have the IP, gateway setup, and I can ping the machine IP itself with no problem. However, I am unable to ping any other machines in the same subnet and other machines cannnot ping this qnx machine either. What could be lost? Thank you.

No! Get it from the original “install cd”!

I got many packages installed.
Now, If I type ifconfig, it will shows both lo0 and en0. Previous it only shows en0. However, en0 has no ip address associated, it only shows that the status is active for en0. I tried to go to Network and type the IP and netmask, and then apply, it shows the error “Could not spawn netmanager” No such device or address. Not show what is the problem now. Previuos there is no such an error though connection cannot be made.

after rebooting the computer, ifconfig will show both en0 and lo0, en0’s status is active, then run command netmanager, and
run ifconfig en0, it will get the following error message:
ifconfig: SIOCGIFFLAGS en0: No such device or address

The exact package name is: QNX Momentics NC for Neutrino (x86)

thanks. From Installer, it shows that QNX Momentics NC for Neutrino (x86) has been installed. But the networking has the problem as described above. Not sure how to resolve it?

thanks for all help, I have resolved the problem by replacing the network card.