no mouse at startup, how do I invoke inputtrap??


I’ve read a bit now about inputtrap but don’t know how to invoke it. Or where to invoke it from. Really a newbie to this QNX/Neutrino6.2.1

Trying to get either a serial mouse or usb mouse going.
Unable to access mouse configure using only keyboard.
Tried various keys but can only access the Configure options that shows mouse but then unable to activate it since I don’t have a mouse and no key seems to act as a hotkey for it.


I had the same problem with my PS/2 mouse.

Frist i started QNX i see my mousecursor but i can’t move it.

i did the following to keep it work:

  1. press the left windowskey to pullup the startmenu
  2. go to configure → mouse
  3. use the TAB-Key to move your cursor to the speed and accelleration
  4. use the cursor keys to adjust the speeds
  5. use the TAB-Key to move your cursor to the APPLY Button
  6. Press spacebar and move your mouse to see if it’s working

hope, it will help you.


Thanks Sirius-3R

I don’t have a mouse pointer appearing, but I tried what you suggested.
But unable to activate mouse configure thru keyboard.
Do you know a hot key combo to do that?

Alternating between a serial mouse and a usb mouse and both at same time to see if???
Thinking of trying a ps2 to serial adapter. What the heck - willing to try just about anything.!!


Under Windows you can connect a PS/2 and a USB Mouse at the same time, no problem. I don’t know if QNX support this.

Uhm, did you checked your Bios? I remember that i had a problem with an Asus Mainbord and QNX. After install and first boot in GUI i have a mousepointer for one second and then it disappears.

There gives an Option in my phoenix bios that let me enable/disable/auto the PS/2 Port.
For Windows was the right option [auto]. For QNX is the right option [enable]

And Second, check in the Bios the option PLUG AND PLAY OS [disabled] not [enabled]

If that won’t work, i can’t help you because i installed QNX my first time one Day ago.

To get a USB mouse working in 6.3.0…

io-usb -d ohci -d uchi -d ehci
io-hid -d usb
devi-hid mouse

…all from within Photon. Post if this works out for you.

Hi cdm

Not using 6.3.0. But I finally did get it to work.
It was a hardware issue.
I’m a little new to modifying my computer and I eventually realized that although I activated the PS2 mouse I had assumed that it would recognize the ps2 mouse thru the serial port. THen while reviewing the mother board specs I discovered an unused connector on the mother board for the ps2 mouse. So the solution was simply to go out and buy the ps2 connector and socket. Works now.