cmdline completion for shell


what i have to do to get command line completion for the korn shell (sh) - does it make a difference when i make a telnet session to my qnx box?


ok i just read the answer: ESC ESC does it - but how can i change this key binding?

From the Neutrino User’s Guide:

If you prefer to use Tab for completing names, set the shell’s complete
key binding by typing:

bind ‘^I’=complete

on the command line or in the ksh profile. For more information about
the bind command and the key bindings, see “emacs interactive input-line
editing” in the documentation for ksh in the Utilities Reference; for
information about the profiles for ksh, see also “Configuring your shell”
in Configuring Your Environment.

I guess this does not apply to QNX 4.25.

Do you have any idea how to set tab completion for ksh?

ESC ESC does not work on my system nor setting to a different key.


Hello back,

I have installed bash-2.0.2 into my QNX4 bin folder at it has the tab completion support. My new question is how can configure my system to start with bash shell default instead of ksh. I checked to see an /etc/shell file like in Linux boxes but none was exist.

In /etc/passwd file you can tell which shell is going to use every user.

Juan Manuel

Thanks. Now I have tab-completion :slight_smile:

This has been bugging me since the dawn of my qnx 4 usage…
I finally decided to check the forum to see if anyone’s figured it and sure enough, they have!!