How to turn off System bell

Quick one: How can I turn off the system bell/beep? It beeps everytime I delete too far, tab-auto-complete etc. in the terminal and I fear I may go insane.



Personally the easiest approach is pulling the speaker wire off the motherboard. However if it is just the shell you are having problem with, you can put this is in your .bashrc:
bind ‘set bell-style none’

and at least the shell will be quiet.


Not sure about pterm since I am a X Window guy :slight_smile:

In “xterm”, I can do “Ctrl” + middle mouse button click to bring up a menu where I can choose to “Enable Visual Bell”.

Also the trick…

ln -sP /dev/null /dev/con1

…works wonders but only lasts until the next reboot.