LAN card problem

Hi everibody,
I have a serious problem with LAN card.
I have a U.S.Robotics us7900 lan card,
not recognized automaticaly.

I use

io-net -d ne2000 -t tcpip
ifconfig en0
ifconfig en0 up

and it can ping itself, showing as lo0 in netstat -nr

I use

route -n add
route -n add default

but I can’t ping any another box.


is it correct load us7900 as ne2000?

thanks for all,

I have the same problem with broadcom 4400,
even if I use

io-net -d bcm4400 -p tcpip


Not sure about us7900 card. A search of “us7900” on google doesn’t show this card. Does “ifconfig -a” show the MAC address for en0? You might want to post the output of “ifconfig -a” and “pci -v”.

As for broadcom 4400, you should check out phearbear’s website at

thanks for all.
using io-net -dtulip -ptcpip
and enabling dhcp-client,
it’s well.


I have the same problem with my Broadcom 4400. I tried Phear Bear’s driver but nothing has changed!! It just won’t connect to the internet, how can i solve this?

I guess “ifconfig” still doesn’t show “en0” interface?

Let’s see what phearbear has to say. I remember he mentioned he had a newer test version to fix some other guy’s problem …

In the meantime, have you tried to specify the VID, DID (as found in “pci -v”) manually?

Oh, it’s ok now! It does work! Thanks! :slight_smile: