No Keyboard or mouse on Boot CD startup

Hi all

I tried installing QNX 6.3.1 burned from the downloadable .iso yesterday. Everything went smoothly until the first graphical screen (asking about my video card) appeared. Neither my keyboard nor my mouse were able to accept any choices, and appeared to be disabled.

Both of these items are connected by USB ports to the motherboard (not via a hub) to enable reasonably fast booting into WinXP. Can I not install QNX with USB Keyboard and Mouse? (My PS/2 ports are damaged and cannot accept connections.)

Any help appreciated

LJ Dellar

You might be able to get away with something like a F1 F3 safe mode that will prevent Photon starting up. I believe that USB keyboards still work in text mode so you will be able to add USB support into the startup scripts that way.

Thanks for that, but I already tried. What I get when I run a verbose setup is about a hundred lines saying something like “Can’t get sense”, then a final line in BOLD text saying something like “Can’t find QNX Filesystem to mount”

Any further ideas?



Okay, first step is to wait for “Detected EIDE. Scanning for devices.” then press SPACE. That way you miss all the SCSI sense messages.

The lose of filesystem doesn’t make any sense to me as you were booting just fine in the previous post.

Yeah, Weird, huh?

The very first time I used the disk it went all the way through to the first graphical screen, then subsequently it stops at “Can’t find QNX Filesystem to mount” every time.

I’m going to try a few more things now and post back if I can get anything working…

Thanks again (what a great forum!)


OK, well I have had another go at installation.

I created a FAT32 logiical partition on my main hard disk (35 Gb out of 160 Gb, the remaining amount is allocated to my NTFS Windows C:\ partition).

I rebooted with the QNX CD in my first CD drive and pressed the spacebar as soon as I saw the “Checking EIDE controllers” message.

I made the following choices:

I forced a partition installation, I chose the only hard disk that QNX discovered (the main one mentioned above) as QNX did not discover the other two 40Gb drives I have on a SiL 0680 SCSI RAID card. These are configured as separate drives, no RAID being implemented.

Although QNX found my Windows partition and the FAT32 partition I had prepared, (plus three empty ones that I do not have!), it said that it could not install QNX on any of them.

I chose to delete a partition to make room for QNX (the FAT32 partition), which the installer let me do, I chose the biggest size offered (I think 14Mb or 14Gb, I did not look that hard), then specified the source as CD drive 0, my first CD drive where the QNX disk was located.

I then got the following…

Restarting driver and mounting filesystems
Executing devb-eide blk auto=partition eide nobmstr fullscan
Path=0 - Intel 82801BA
target=0 lun=0 Direct-Access(0) - HDS722516VLA20 Rev:3VO4
Path=1 - Intel 82801BA
target=0 lun=0 CD ROM(5) - AOPEN 16xDVD-ROM/AMH Rev:R13
target=1 lun=0 CD ROM(5) - AOPEN CD-RW CRW2440 Rev:1.00

Unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase
Partition installation aborted!
Please remove the install floppy and CD, then reboot your machine.

Should I have created the FAT32 partition as a PRIMARY rather than a logical one?

I still can’t understand why I got as far as a graphical screen part of the install on the first installation, and have never gotten there again since…



QNX installer doesn’t support two CD/DVDROM. I suggest you disconnect the one that you are not using for install. Once installation is done, you can re-connect it.