Shell Script in Build File

Hi All,
I have a shell script that i want to run when the image boots up. I tried adding it in the build file like this:
[+script] .script = {



When I boot up, I get this:
Unable to start “./demoScript” (13)

I thought it was the exec permission so i tried chmod 777 before the script, but I get no file or directory error, even after I gave it an absolute path. However, i can see the file in the /proc/boot directory. I’ve also tried to run demoScript at command line and got “can’t run demoScript, permission denied”, but when I tried chmod 777 demoScript it tells me no file or directory.

Can someone please help?
Thank you in advance.

demoscript is a shell script? Is the shell that it requires available on the path?


Yes demoScript is a shell script. The shell is in the /proc/boot directory.

Does the shell script start with #!/bin/sh or #!/proc/boot/sh ?


Hi Rick,
It starts with #!/bin/proc/boot/sh. I got this part working, but I can’t get the PhAb apps that I built to work when I include them in the build file. The work fine when I drag and drop them into flash, but they won’t work when they are embedded in the image.
Thanks for your help.

Phab apps contain a data resource that gets stripped out by mkifs. You need to put the [+raw] attribute before your phab app, or use the -p option
to mkifs

Thanks, CBurgess.
The [+raw] attribute worked.
Thanks, again.