Elotouch Touchscreen

I have recently purchased an Advantech PC with an Elotouch restitive
touchscreen ( i do not know the controller model number and neither does
advantech tech support, they must ask advantech in taiwan for this
information). Anyhow, at first we tried to use the intellitch protocol
without any success (could not get acalib to work). After conferring
with Elotouch, we tried the smartset protocol and got it to work (acalib
worked perfectly). However, when trying to use the touch screen, we
found a couple of problems:

1)At the top of the screen, we found that the function was normal, but
as we moved down in a straight line, the cursor jumped ahead of the
touchpoint in the -y direction at a certain point and as we continued to
proceed farther, the offset became greater. Moving in the horizontal
direction posed no problems.

  1. In a vertical band about 1 inch from the left corner of the screen,
    the cursor becomes offset 2 inches in the +x direction and exhibits the
    same problems seen in item 1 above.

Any responses are greatly appreciated! Thank You.

Dan Szymanski