new QNX 4.25 G installation - photon problem

I have just installed the QNX4.25 patch G runtime OS on a PC, and I am getting the following errors that I am hoping someone may have some insight on:

when I start Photon:
“couldn’t open ////.photon/pwm/pwm.cfg for read”
(what is this file? I do not have a pwm directory under .photon)

when i attempt to change photon display resolution:
“unable to register name: Resource busy”
(I think this one is causing my problems with not being able to change my resolution… I don’t know where to start looking for the problem though)

a little background: I transferred my crt.1 file from my older patch version to this version and it doesn’t work the same. I tried some other crt.1 files, including original, but it hasn’t made a difference. one crt.1 file that i tried wouldn’t even load photon, it just gave me some error and stopped trying ( this crt.1 file was from my development PC which works fine!).

Can anyone point me in the right direction?

That’s because the home directory for root is set to ‘/’. Change it to something else ‘/root’ for example, if you want to get rid of the error.

Exit Photon, run ‘crtrtrap clear’ and then ‘ph’ and see if you can select the resolution you want.


maybe you should read ‘crttrap clear’ - without the inner ‘r’ between the 't’s.
for me it worked simply to delete crt.1 file and restarting photon.

regards HELGE

yeah, speeling gets you every time… ;-)

All ‘crttrap clear’ does is erase that file. ;-) It is just easier to type than the whole path to the file.


i didn’t want to interfere with your advice actually. only sometimes i wasted a lot of time typing in ‘slightly’ misspelled or rather mistyped commands.

so that’s what crttrap clear does … interesting … you always learn by visiting the forum !
regards HELGE