& Netgear MA401 (WLAN)


I have bought the Netgear MA401 PCMCIA card which is listed at the supported hardware, because the network card inside my laptop isn’t supported by QNX.

Now I try to get them running at QNX6.2.1B.
For the first tests I switched off the WEP encryption.

Here is the output of “pin”:

Sock Func Type Flags PID Base Size IRQ
1 0 Network C—I-±–X----- 81933 0x300 64 7
1 Empty ----MF---------- None
2 Empty ----MF---------- None
2 Empty ----MF---------- None

Here is the output of “pin cis”:

Socket : 1 - Function : 0
Device : Null 0k
Attribute Device : SRAM 1k
Other conditions (att) : MWait
Attribute Device : SRAM 1k
Card tuple version : 5.00
Manufacturer : NETGEAR MA401RA Wireless PC
Name of Product : Card
Add’nl info (lot #) : ISL37300P
Add’nl info (programming): Eval-RevA
Manufacturer ID : 0xb 0x7300
PC Card function : Network LAN Adapter
POST : 0x0
Tuple 0x22 link=2 : 01 07
Tuple 0x22 link=5 : 02 40 42 0f 00
Tuple 0x22 link=5 : 02 80 84 1e 00
Tuple 0x22 link=5 : 02 60 ec 53 00
Tuple 0x22 link=5 : 02 c0 d8 a7 00
Tuple 0x22 link=2 : 03 07
Tuple 0x22 link=8 : 04 06 00 09 5b 54 8d db
Tuple 0x22 link=2 : 05 01
Configuration base/st : 0x3e0 0-subtuples
Configuration Index : 0x1 Last Default
Interface : I/O
Feature : 0x19
IO Space : Bus16 0x0-0x3F(6 lines)
IRQ Description : Pulse Level VEND BERR IOCK NMI 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

Then I used the following commands:

slay io-net
io-net -d prism mode=bss,station=qnx,verbose -p tcpip -v
ifconfig en0 netmask
route flush
route add

From the prism driver I got the following output:

PRISM (prism)

Vendor … 0x0
Device … 0x0
Revision … 0x0
I/O port base … 0x300
Interrupt … 0x7
MAC address … 00095b 548ddb

Then I tried to ping my WLAN router:

PING ( 56 data bytes
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
---- PING Statistics----
13 packets transmitted, 0 packets received, 100.0% packet loss

At the “nicinfo” command I see, that the card and driver founds my WLAN.
The SSID and channel is right !!!

PRISM (prism) 802.11 Wireless Ethernet Controller
Physical Node ID … 00095B 548DDB
Current Physical Node ID … 00095B 548DDB
Media Rate … 11.00 Mb/s half-duplex WIRELESS
MTU … 1514
Lan … 0
I/O Port Range … 0x300 → 0x33F
Hardware Interrupt … 0x7
Promiscuous … Disabled
Multicast … Enabled

Total Packets Txd OK … 0
Total Packets Txd Bad … 0
Total Packets Rxd OK … 4
Total Rx Errors … 0

Total Bytes Txd … 0
Total Bytes Rxd … 0

Station Name … qnx
Network Name (SSID) … default
Channel: … 6
BSS Type … BSS

Here is the the output of “ifconfig”:

lo0: flags=8009<UP,LOOPBACK,MULTICAST> mtu 33212
inet netmask 0xff000000
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet6 ::1 prefixlen 128
address: 00:09:5b:54:8d:db
media: autoselect
status: unknown
inet netmask 0xffffff00 broadcast
inet6 fe80::209:5bff:fe54:8ddb%en0 prefixlen 64 scopeid 0x2

Any idea’s whats wrong ?
The driver founds my WLAN SSID and channel.
Why does it not work ?

Thank you very much for your help !!!

Best regards


Has nobody an idea ?

How can I ensure that it’s not an interrupt problem or similar ?

I forgot to say, that the WLAN card works fine under windows.

Best regards


Try running this on startup:

slay io-net
/sbin/io-net -p tcpip -d /lib/dll/ channel=10, ssid=linksys, station=qnx,verbose
sleep 5
/sbin/ifconfig en0 netmask
/sbin/route flush
/sbin/route add

You will need to change linksys for the ssid of your wireless hub, and also change the for your own IP address, and for your gateway.

Hello thegman,

I have put your commands into the file “/etc/rc.d/rc.local” and removed the spaces from the options of the prism driver.

I got the same error and outputs as before.

Have you also an MA401 card ? Get you the same output at “pin cis” ?

Best regards



Just a wild guess. Maybe it’s your IRQ (7). Try to slay your devc-par before kicking your nic to life. If it works, try to assign another IRQ to your nic.

I’m not sure if it helps. It solved my problem with a PCMCIA adapter once.


Hello fmartens,

devc-par is not running. I get the following error while booting:

Unable to open device /dev/par1. (No such file or directory)

I slayed all processes which are not needed, restarted devp-pccard and net io-net.
But I get the same error.

In the past as I installed SuSE Linux 8.1, I had problems with the interrupts.
I had to use the following boot switch to get the interrupts working:


I am no ACPI/APM expert, but does QNX use it ?
How can I ensure that it’s not an interrupt problem ?

Best regards


Hello fmartens,

But if I remember right, Linux showed interrupt 0 for the built in network card before using the boot switch.

Under Win2k the MA401 PCMCIA card gets ISA interrupt 11.

Best regards


Hello fmartens,

I can remove the error message about /dev/par1 when I set the I/O and interrupt configuration from the parallel port in the BIOS from auto to maunal.

That looks really like an interrupt problem.

What can I do ?

Best regards