QNX 6.21 Blown TCP/Ip stack with slow network connection

We are using QNX 6.21 Standard Edition with Development environment.

Hardware information:
CITSM Full-Size Socket 370 CPU Card. The built-in network card is Intel 82559.

When I tried to fetch a big file (more than 20 MB) from other machine via ftp, I always got the “Blown stack handling 0x102, see “stacksize” option”. I have tried different stacksize for “io-net” option (from 3000 to 11648 or bigger) by changing the /etc/system/enum/include/net file, it always has the same problem.

By “nicinfo” we could see the Media rate is 10.00MB/s Half-Duplex UTP since we are using a hub. If we use high speed connection (100MB/s Full-Duplex UTP), there would be no problem at all. We could easily transfer file with more than 100MB.

As a matter of fact, we do have to use the slow network 10.MB/s, then how could we get it work?

Thanks for any help,

Sounds like a bug, have you tried the last version of QNX 6.3 ?

Thanks for replying.
Yes, I tried. Same problem.

For the BIOS settings, I simply load the fail-safe mode, enabled USB mouse and disabled PNP. Nothing else.

Can you post the exact io-net line (pidin -P io-net args should work). Just want to make sure you are actually giving the stacksize argument to the npm-tcpip.so module, not something else. ;-)


io-net -ptcpip stacksize=4096

Yeah, ok. Just checking… ;-) Does sloginfo show anything interesting? The other option is to make the stack really large - although I can’t imagine why that would be required other than a bug of some sort. I have certainly ftp’d files larger than 20M without problems - albeit with a different network driver.


Ge something wrong while start up:
scsi_interpret_sense: error=70, sense=5,asc=24. ascq=0
scsi_interpret_sense: SKILLEGAL command 35 in datatype

Sorry don’t know why and how that happened.

Nothing for the transmission though.
It seems io-net (8 of them) got into the some sort of deadlock situation. BTW, we do have QNX 6.2.1 running perfectly on other machine which has the different hardware.

The scsi_* stuff is just from the disk startup - even if you don’t have a scsi drive, eide uses the same commands and you will see complaints if you have a drive which isn’t 100% compliant - often a CD drive.

So it appears you have bug. Report it to QSS and see what they say. ;-) Good luck.


Thanks a lot.

When you say “same problem with 6.3”, did you mean same problem when using everything from 6.3? Or you just took the 6.3 npm-tcpip.so?

Have you tried use io-net from 6.3 (and everything else could stay in 6.2.1)?

i’m new learn QNX system pelase help me?My contact me rafisevis@msn.com

I installed QNX 6.3 Standard Edition on the machine and transfered the same file using FTP. Blown TCP/IP stack error still existed. I could see all 8 io-net threads were still running.