Installation problems

I must install QNX RTP 6.1 on my system, but I’m having a lot of
problems, I hope someone can shed some light on them. Here is my system

Asus A7V, Duron 700 MHz, 256 Mb RAM
Asus GeForce2MX, SBLive
nothing on the “normal” primary IDE channel
Plextor CDRW as master on the “normal” secondary IDE
IBM 30 Gb HD as master on primary Promise ATA100 IDE
Quantum 6.4 Gb HD as master on secondary Promise ATA100 IDE
Adaptec 2940 SCSI PCI card
other unimportant stuff

The partition for QNX is the 4th primary partition on the 6.4 Gb HD, an
1.1 Gb partition.

With this config, the “test” boot from the 6.1 CD works fine, I can use
the system.
But when installing, booting the CD from the SCSI drive, I get a “can’t
find /dev/hd0” error (can’t remember exactly the words, sorry, but it WAS
/dev/hd0). I suppose the HDs are not recognized.

So I tried moving the HDs on the standard IDE channels, again both as
master on different channels; I didn’t get the error anymore, but I got
an empty HD list, so nothing again.

I then set them as master and slave, and they were finally recognized.
But, after doing all my choices, I got an “unable to mount /dev/cd0 as
/cd” error. I also tried selecting “cd1” when requested from which
filesystem to install (how can I know which one is the right choice?),
but I got an “unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase”

So I tried booting from the IDE CDRW, and it finally worked! The
installation seemed to complete fine.
But… when booting it, I get the normal “Press ESC to…” message, then
a lot of dots “…” while it reads from the HD, and it finally
stops, and the system hangs.

Any clue?

Thank you very much in advance.