QNX 6.2.1a problems


I am new in QNX world, therefore I would like to ask some professionals to help me answer the following questions:

Please note that I run on Digital Celebrix P5 (x86) box with 96M RAM.

  1. how can I swap/replace .boot and .altboot files. Seems it can not use DMA, but ESC does nothing. From other side it boots perfect from CD and start automatically my QNX from HD.

  2. gcc does not work…

  3. autoconf fails even with cc

  4. bash crashes with core dump

… and I used QNX just two days.
There must be something that I missed.

Otherwise I like very much the installation, especially the online repository idea.

Any help would be appreciated.
Thank you in advance.

Regards, Z

  1. The default install has .boot in DMA mode IF it supports DMA with your chipset. Look in the output of sloginfo (at the top) to see what modes the eide driver is using.

  2. gcc certainly does work if you install the Momentics packages. Otherwise you don’t have gcc.

  3. If you install all the GNU build tools they work on QNX.

  4. How/when does it crash? I have been using bash under QNX6 for more then 3 years (6-8h/day) and never once had it crash.


thank you for help…

I reinstalled the whole box and installed everything available from all repositiries that have been offered.

Now bash works perfect.
BUT gcc does not work. Typical crash look like:

gcc -O2 -Wall -W -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline finger.c -c
gcc: Internal compiler error: program cpp0 got fatal signal 11
make: *** [finger.o] Error 1

There is yet another problem:
when I include php4_module in apache. It crashes with:

Syntax error on line 205 of /etc/apache/httpd.conf:
Cannot load /opt/lib/apache/mod_vhost_alias.so into server: Not enough memory

… even if there is no sytax error in line 205 nor around php module.

Thank you for offered help.

  1. gcc problem: looks like you don’t have enough memory. How much memory do you have? thought QNX GNU tools is configured to use “swap”, but maybe that is just a plan from QSS. Add more memory and you should be ok.

  2. php problem: I never used the 3rd party CD version but I just tried the php/apache from
    openqnx.com/modules.php?op=m … =0&thold=0

and I don’t see such problem. Maybe your download is corrupted? or your config is no good? Or maybe you do run out of memory as indicated by the “gcc problem”.

btw, you keep talking qnx 6.2.1a. is it out already? i am so out of date in the qnx world.


I run:

uname -a

QNX qnx.polarhome.com 6.2.1 2003/01/18-02:12:22est x86pc x86

but I saw somewhere this “a” as well.

It has 92M RAM… and it was far enough to run all these applications with Linux 2.4.18 earlier. It must be some configuration problem.

Sorry if I ask dummy questions.


The gcc issue must be in the file finger.c. It is possible that if you hvae binary data inside of the file that the C Pre-Processor could die or get into a cycle. Care to put the code online somewhere for others to look at?

As for the apache/php thing, the 3rd Party repository version (using the shared libphp4.so) has a problem. I am not sure if the version noc did links php into apache or uses it as a mod. You could either download his version or just use php as an external cgi handler as apposed to an internal mod.


unfortunately gcc fails on simple “hello world” like programs.
… also qcc compiles without any problem, but does nothing when I start the program.


cat test.c

#include <stdio.h>
printf(“hello world”);

gcc test.c -o test

gcc: Internal compiler error: program cpp0 got fatal signal 11

cc test.c -o test


Strange. I haven’t seesn this kind of behaviour before on any other OS.

Regards, Z

The problem is that QNX doesn’t support normal swap becuase of restrictions placed in realtime environment (swap has an unbounded latency). gcc needs a large amount of RAM to run. So gcc can choke on it.

You can see how much ram is free by using command “pidin info”

PS. (my view) The QNX desktop version is meant more for self-hosted development to be carried out in sufficiently resourceful environment.

Because gcc is a memory hog, I remember I read it somewhere that QSS had patched up gcc and tools to actually use swap even though QNX doesn’t normally support swap.
cdm, can you confirm this?

Yes, gcc and ld both use swap. In fact, that hack for swap on x86/Neutrino was added in purly to get the GNU toolchain working.

However, gcc only uses a lot of memory when you enable optimizations. To me this sounds more liike a corrupt install. I have run gcc just fine on machines with only 64M of memory.

Zoli - could you please post the output from “gcc -v”? As for the test issue, you are making a very common UNIX newbie error. First, . isn’t in your path (current dir) and test is a built-in shell command. So you are not actually running your program. Try doing…

cc -o foo test.c


gcc -v

Reading specs from /usr/lib/gcc-lib/ntox86/2.95.3qnx-nto/specs
gcc version 2.95.3qnx-nto 20010315 (release)

cc -o foo test.c


there is not output at all… :frowning:


Zoli - I just noticed your code says mail() and not main(). Is that just a typo on your part? Otherwise, I can only assume this is a corrupt install, having never once seen or heard this issue with anyone running QNX in the past 3 years.