QNX 6.2 tcpip IPv6 question


I haven’t find any document that describes IPv6 setup on QNX 6.2.1a.
I am quite faminiar with NetBSD and QNX does use NetBSD tcpip stack, but ifconfig does not want to accept inet6 parameters.

Do I need to use some special not documented tcpip parameters during net-io load?

Thank you in advance.


You need to have QNX Momentics Profesional Edition installed.
Namely you need to have /lib/dll/npm-tcpip-v6.so, and have
npm-tcpip.so link to it.

Here is an output on my machine:
$ uname -a
QNX dragon 6.2.1 2003/01/18-02:12:22est x86pc x86
$ ifconfig -a
lo0: flags=8009<UP,LOOPBACK,MULTICAST> mtu 33212
inet netmask 0xff000000
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet6 ::1 prefixlen 128
address: 00:00:e2:6c:b2:b3
media: Ethernet 100baseTX half-duplex
status: active
inet netmask 0xfffff800 broadcast
inet6 fe80::200:e2ff:fe6c:b2b3%en0 prefixlen 64 scopeid 0x2


thank you for help.
I run QNX Momentics Personal Edition, and I do not have that library at all.

I understand from release notes that tcpip stub has support, but not that it is not included in Personal edition. :frowning:


PE does not mean “Personal” it means Professional. If you downloaded QNX you have NC (Non-Commerical) and you do not have the v6 stack.


that’s the problem. I use downloaded QNX.

BTW do you know how much might cost an PE for one cpu and for non-comercial use.

click the FAQ link from the left navigation bar to find out the prices.
BTW, there is no such thing called PE for non-commercial use. PE is for
commercial use and you pay the same price for one cpu or more cpus.
NC is for non commercial use and is free.


seems here ends my QNX adventure.

$ 4k is far more that I can appreciate for PE.
IPv6 and compilers do not work with NE, no user quota and web server dies with PHP.

My intention was to introduce QNX to users as I did with OpenVMS, Linux, *BSDs, Solaris, AIX and HP-UX at polarhome.com .
I can imagine that QNX is extremely good RTOS, but it is not designed for multi-user environment and secially not for public usage.

I would like to thank everybody who helped me to solve my problems so far, especially cdn for fast and competent answers.
Thank you.

Kind regards,

I am not sure what you mean that it isn’t ment for multi-user environemtns? We run qnxzone.com as a multi-user environment and website based on the NC version of QNX. It works great.

Hi, I have a question similar to the one from zoli. I have 3 machines running QNX Neutrino 6.2.1 PE (Professional Edition). I want to make a small test on HAT/HAM which runs on multiple nodes. I learned from the documentation that in order to connect to remote HAM I must run QNET networking. And QNET uses NDP (Network/Node Domain Protocol) as resolver by default. To make connection to a remote HAM I must define a node number or a node name. I use /etc/hosts to define the mappings between nodename and IP address. My problem is, I still can’t connect to remote machine using the /net mount. I tried to use ndp tool to view the machines on the network (ndp -a) but it showed nothing. What’s wrong? Did I miss something? Mr. Igor told me that ndp uses IPv6. What should I do to make it works?


When you say “ndp”, Igor is probably thinking of something else.

QNET is part of NC/SE/PE, it just did not start by default.
On your machine, try “touch /etc/system/config/useqnet”,
and reboot them, you should got your /net.