Installing QCC

I was succesfull last week in installing QNX. I just don’t know how to compile a C program in QNX. I searched online and found that qcc is a compiler for qnx. I downloaded the ISO and installed on my laptop. When I open the installer, I see that there is a C++ compiler. I just don’t know how to invoke it.

I am also not sure how to install software using the installer.

I tried qcc,q++,gcc,g++ on the terminal only to find that everytime I type it says bad command.

Any help is appreciated.


What version of QNX have you installed?, “uname -a” gives answer.

Thank you evanh for your response.

I am using QNX 6.2.1.

I had tough time recovering the password on this website. I had to create another account for replying you. This website was sending me the codeword everytime and not the password for me to reset.

Anyways thanks for your help.

I guess it’s the same old problem … you need to complete the installation by poking the CD back in drive and run up “Installer”, then install the patches to give you the “Momentics” installation.

Thank you for your response. I am not sure what you meant by “its the same old problem”. When I run Installer after keeping the qnx cd back in the cdrom, it gives me a series of packages under the “My Installed SOftware”. The status says all those packages are installed including GNU C++ library. (Version 2.2.10).

There is also an option of Select All and Clear All. When I click on select all, all the packages are selected. I dont know what to do further. I dont have any apply kind of a button.

I am not sure how to install patches to get to the “Momentics” installation. Any help is appreciated.

Do you have a “QNX Momentics for x86” in that list?

If not then, from the CD, first install both “QNX installer for Neutrino” and “QNX updater for Neutrino”. Then, restart the installer and you should see “more” stuff on the CD. Choose to install “QNX Momentics for x86”

Hello Evanh,
Thank your for your reply. I was tweaking the cd back into the cdrom and it was always complaining that those two packages had problems in installation and the operation just aborted.

I was tweaking here and there and found that my “installer” isn’t working either. I mean when I click on installer on the menu, nothing was coming up.

There was one option in the Launch->Software → Old Installer.It gave me option of QNX repository on WWW.

As I was able to connect to the internet through lan cable, I immediately connected it and I downloaded the updates of QNX real time platform and it worked like charm. This is really cool. Even my graphics card was recognized and I can view everything with a 1024x768 resolution unlike some 600x300 resolution earlier.

Anyways thank you very much for your help. I just compiled my first Queeenix C Program.

Thank you once again,

Cool, glad to see you sussed it. :slight_smile:

I can’t actually remember the details myself as it’s been just too long since I last installed 621, that info was pasted from what noc had said a while back. It’s entirely possible that the old 6.1 installer was the one that needed to be used to do the upgrade with.