VIM 6.3 on QNX4.25 wont compile

I am trying to compile VIM 6.3 on QNX4.25 with no luck. When I compile I get this error.

os_unix.c(1127): Error! E1011: Symbol ‘SA_ONSTACK’ has not been declared

I have seen in the documentation that I should use termlib.o but I do not have this file either. Can anyone help? Maybe someone has already built this and can send it to me?

I have VIM 6.2. Not sure if everything is pk though, i could never get the syntax highligh to work properly (maybe it’s a config issue)

Can you help me to compile version 6.3 or send me a copy of your 6.2?

I have the windows version of VIM 6.3 running with syntax highlighting and all I needed was to add this to the _gvimrc file

" Switch on syntax highlighting if it wasn’t on yet.
if !exists(“syntax_on”)
syntax on

Is this what you are doing?

I really like this color scheme
colorscheme darkblue

also to set a font that shows Japanese characters
set guifont=MS_Gothic:h10:cSHIFTJIS

Sorry, I know you did not ask for any of this.

The file is 9 megs, I try attaching it to the post but it didn’t work. How can I sent it to you?

Hopefully you should be able to just run make install :wink: Running ./configure could cause problem because from memory (that was a while ago) I customized config.h manually…

I tried to post the file again, but to no avail sorry

If you have a yahoo account you can drop it in my breifcase. If you don’t I will work on an FTP site you can put it. Thanks for your help!

I tried make install and I get the error shown above.

I do have a yahoo account, but I got no idea how to use that breifcase stuff. I try to find how to upload to no avail?

Mario, you can ftp to and drop me a note so that I can move it to a download area on sf.

Upload as I type this. I’m not sure anyone can compile this since you would have to run configure first to override the hardcoded path my configure session created. Plus I had to modify the config.h file and source here and there, you would loose these change if you run configure. However it should be possible to use the binary.

The file is now available at sourceforge.

Just a quick question. What is the preferred location to copy the files to (such as support files, etc) with your package? I ran the vim binary solo and I’m just really happy to be able to use it under QNX4, thanks a lot!

I have no idea :wink:

I assume a quick “make install” will do the job.

Here is from the Makefile

I had tried that but it started to recompile. It appeared to be a timestamp issue. From the directory where I extracted the files, I did ‘find . -type f -exec “touch {}”’, followed by a ‘make install’ and it worked.