Network & Sound


I have a problem my network card and sound card.

My network card is SMC EZ Card 10/100 1255TX. Ok, I find in the help, this card driver is “”. I run in terminal: io-net -d tulip -p tcpip

Ok. I open network config tab… and I not see en0. I tried in terminal (help example) “ifconfig en0”… No such device… damn

In terminal I typed “pci” command, I copy it:

PCI version = 2.10
Class = Mass Storage (IDE)
Vendor ID = 1106h, VIA Technologies Inc
Device ID = 571h, VT82C586/686 PCI IDE Controller
PCI index = 0h
PCI IO Address = d000h enabled
PCI Int Pin = NC
Interrupt line = no connection

Class = Network (Ethernet)
Vendor ID = 1113h, Accton Technology Corporation
Device ID = 1216h, EN2242 Accton EN2242 PCI LAN
PCI index = 0h
PCI IO Address = dc00h enabled
PCI Mem Address = df000000h enabled
PCI Int Pin = INT A
Interrupt line = 11

Class = Multimedia (Audio)
Vendor ID = 1274h, Ensoniq
Device ID = 5880h, 5880 AudioPCI
PCI index = 0h
PCI IO Address = e000h enabled
PCI Int Pin = INT A
Interrupt line = 5

Class = Display (VGA)
Vendor ID = 10deh, Nvidia Corporation
Device ID = 150h, NV15 GeForce2 GTS/Pro
PCI index = 0h
PCI Mem Address = dc000000h enabled
PCI Mem Address = d0000000h enabled
PCI Int Pin = INT A
Interrupt line = 10

What the problem? I see the help, but I can’t make it…:frowning:

My sound card is SB PCI 128… I haven’t sound. Why?

Thanx. And sorry my poor english.


Try using for the network driver.

Assuming you are using QNX 6.3.0, audio is prolly not a driver problem but rather a lack of mp3 decoder, here is the decoders … … lease_id=6

You might also get lucky with using for the graphics driver too.

Thank you, but unfortunately not working…:frowning:

I typed io-net -d rtl -p tcpip, and the message was:

“unable to init dll devn-rtl: No such device”

My QNX version: 6.2.0 (Non Commercial).



Hmm… Anything else? Someone? Pls.

Give 6.3.0 a try.

Ok. Thank you. I’ll try.

It!s work. Thank you.

Other questions: How can I setup my network device automaticaly? Actually I start network device manualy every stertup, with terminal command.

Put the the commands into your rc.local file.

Thank you.

You can also make an enum file instead. Read up the section in the User Guide, … numeration

There is this choice litlle tidbit, “The enumerator reads and concatenates the contents of all configuration files under the chosen directory before it starts processing.” Which means that you can add as many extra files as you like.

As an example, I’d copy the lines for, assuming that’s the one that works for your chip, from /etc/system/enum/devices/net to a new file called, say, /etc/system/enum/oem/devn-rtl and add a new “device” line for the device ID of your controller chip.

This file is now an override for the realtek network driver enum.

My sound card did not work, too. I have used QNX 6.2.1 NC. How can I fix this problem, (I can not get QNX 6.3.0)?