QNX 6.3 on a Thinkpad R51 ?

Hello QNX gurus,

recently I downloaded 6.3 and installed it on a spare partition in my Thinkpad R51 laptop. It all installed smoothly and booted to Photon. However, the only video driver that actaully works is the VGA with the 600x480 resolution.

I’ve tried all other drivers and various resolutions, including the ‘radeon’ and ‘radeon 90’ drivers - they kinda work, meaning that I can see the screen being drawn correctly, but all that comes with a very intense flicker, one that makes it totally impossible to do any work.

Here is what ‘lspci -v’ tells me about my graphics card:

0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA])
Subsystem: IBM: Unknown device 0530
Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel, latency 66, IRQ 11
Memory at e0000000 (32-bit, prefetchable) [size=128M]
I/O ports at 3000 [size=256]
Memory at c0100000 (32-bit, non-prefetchable) [size=64K]


Has anyone had any success with QNX on a Thinkpad?
Would anyone have any suggestions on how to configure the system to achieve anything better than 600x480 ?

thanks in advance,

Leszek Koltunski

Go to the Display Settings control panel and click the ‘Advanced…’ tab, there is a line of text in there that should contain ‘refresh=60’ or another number, try setting this to whatever you have it set to under Windows, 60 is fairly normal. If it’s much higher or lower than that, then that could be your problem.

You might also want to get the updated driver:


You could also try getting evanh’s vesatweek driver, this can give very good performance (better than the native Radeon driver, for some things).



One problem with LCD’s is they can’t handle anything other than 60 Hz display rate. And since a lot of the QNX drivers miscalculate the timings a little you should be able to fix the radeon driver by adjusting the refresh setting off the target rate by a couple of clicks. I would start by decreasing the value first, 59 then 58 then 57 and so on down to 50 then 61, 62, 63 up to 70.

Thanks for your replies, guys. I’ll try all that tonight after work and report on my findings!

I’ve tried your suggestions. The problem however is that now Photon starts with the ‘radeon’ driver and the whole screen immediately starts flickering, so I really cannot do much. I know how to boot QNX to the console however; is there a way to tell photon to use the “vga” driver on startup?

Have you tried pressing Escape for altboot on startup, maybe one of the safe modes will let you boot without the flickering.

ph -s

yes, I already read the ‘ph’ script and discovered the ‘-s’ option, but when I use it, then even though Photon boots to the safe vga dirver, my mouse doesn’t work for a change… The ‘-v’ option doesnt seem to work either.

I am a kind of an OS junkie. I’ve installed tens of OSes on different machines including exotic setups like a BeOS MAX on a Toshiba Sattelite laptop, NetBSD on a PS2, but honestly, I’ve never had such weird problems like with QNX’ graphics drivers before.

I wanted to test responsiveness of QNX’ microkernel , but looks like I’ll have to give it up now…

If you just need to try out realtime responsiveness as so forth, then you probably won’t need graphics at all.

But to try to get Photon working… Have you tried out the new Radeon driver, or evanh’s vesatweak driver?

That’s odd behaviour with your mouse.

To reset the mode selection, try the following then run ph again and it should do it’s initial choose your prefered driver selection all over again:

crttrap query //—// Prints the command that will load the graphics driver.
crttrap clear //—// Wipes out the current driver selection.

If you still can’t work with the result then you can edit the current config at /etc/system/config/graphics-modes

crttrap trap //—// Does something like choosing a default for you.

The newest QSS’ radeon driver works for me. I’ve got a nice 1024x768 w/ 32bit color ;)

Thanks for your help, guys. One more question: is there some QNX manual for newbies? I keep stumbling at stuff like the absence of the ‘man’ command or other differences from more mainstream unices.

Also, how about some QNX’ hardware compatibility list? Sound HOWTO? List of repositories?

“use” is the command you are wanting, it pulls the help text from the specified exe, eg: use fdisk

The built-in docs are getting good, particularly the user and command info. Click on the “Help” button or use your prefered html browser and point it at /usr/help/product/neutrino_runtime_en/bookset.html

There are some hints here on openqnx and other places too:
openqnx.com/modules.php?op=m … file=index
openqnx.com/modules.php?op=m … file=index

how do you install the new driver?