Compiling VLC (VideoLan)

I’m trying to compile the most recent version of VLC on 6.3, I’m making progress, but ffmpeg will not compile, it gives the error:

audio.c:24: sys/soundcard.h: No such file or directory
make[1]: *** [audio.o] Error 1
make[1]: Leaving directory `/home/gman/VLC/ffmpeg-20041113/libavformat’
make: *** [lib] Error 2

As I understand it, soundcard.h is only available on Linux, so does anyone know a workaround?

If anyone is working on compiling VLC or ffmpeg, please let me know, make sure I’m not wasting my time!



Yes, I heard John Fehr (a.k.a Wildcard ) from Wildcard Desgin Inc has ported ffmpeg to QNX 6.

cdm may know more about it, but he doesn’t come here very often since he left QSS. You can send him an email

HI ,
I ´m trying to port VLC myself ,3 nd I found quite a lot of problem with compiling the library .
I do not understand why some result are .a or .la instead of .so , any hint ??

I think this happens when the configure file thinks the target OS does not support dynamic linking, cannot make a dynamic library. There is probably a million other reasons why this happens, but I’m guessing it’s the above, maybe check to see if the configure output says anything about the OS supporting dynamic linking. I guess the configure file does not support QNX directly, so makes a lot of assumptions.

If you get any further let me know, I hit a dead end with ffmpeg…

You may want to look at mplayers source, as the included ffmpeg in the src tree builds fine, although i have mplayer built to use SDL for sound output. Last time i built VLC on QNX was version 0.4.4 and i remember it being quite a PITA. Good luck.

Btw, why are you trying to build vlc? Why not just use mplayer instead? It builds dern near right out of the tarball w/little effort.

I have MPlayer running on QNX now, using GTK. I’m more interested in VLC as I have had far more luck with it on other platforms, in terms of being good with a variety of formats. I’m also more interested in VLC as I understand it can use SDL, which I think might be a bit easier to make into a native Photon app, rather than the (rather ugly IMHO) MPlayer.

Hello everyone,
I must develop a DVD player on QNX 6.3 (or 6.2.1 also), but I can not find the dvd plugin that issued in QNX website. What approach can I follow?
By the way, in this topic, we talked about the mpplayer, why can’t I find the mpplayer on my QNX machine (6.3 or 6.2.1), could you tell me where I can find it?
Thank you very much.

I think you missed my post ;-0 Legally you CANNOT. DVD are encrypted, to decrypt them you need a license, that license cost money hence QSS did not include it with the standard OS. You must pruchase the multimedia TDK (6.3.0)

With 6.2.1 the state of the multimedia stuff was in a state of transition that is why you are missing bits and pieces. I think 6.1 had stuff to play DVD (the plug-in) but it was later removed because of licensing issue, plus it had lots of performance issue at the time.

Thank you very much, mario.
I will try buying a license to use Multimedia TDK.

I hope you’re not too tight on your budget;-)

Thank you for your advice :slight_smile:), mario.
By the way, I also want to build VLC on QNX 6.3.0 (in case my budget is not enough to buy the TDK :slight_smile:)). So, I need some help from the others who have built the VLC on QNX successfully. I have already downloaded the VLC source and started to build. First, I run ./configure, but is raises the error after some minutes of running. The error is :

checking whether NLS is requested… yes
checking whether included gettext is requested… no
checking for GNU gettext in libc… no
checking for GNU gettext in libintl… no
[color=red]configure: error: libiconv is needed for VLC to work properly

Can someone help me know what the [color=red]libiconv is and how I get it?
Thank you very much for your help.

Thank you very much, noc.
I have just downloaded and installed the libconv (iconv1.9.1) and its dependency(gettext0.13) into my QNX machine, but I also received the same error:

[color=red]checking for iconv… no, consider installing GNU libiconv
checking for nl_langinfo and CODESET… no
checking for LC_MESSAGES… yes
checking for bison… bison
checking version of bison… 1.35, ok
checking whether NLS is requested… yes
checking whether included gettext is requested… no
checking for GNU gettext in libc… no
checking for GNU gettext in libintl… no
[color=red]configure: error: libiconv is needed for VLC to work properly

I have no idea to resolve this error. Please help me. Thanks.

By the way I’m pretty user that with VLC you will not be able to play commercial DVD.

Hello mario,
It means I have no way to develop a DVD player except buying a license of Multimedia TDK, is that right?

Yes that is right, if you want to play encrypted commercial DVD (most movies) I’m not aware of any other solution.

Hi mario,
It’s a long time since I saw you. I already have a Multimedia TDK for QNX 6.3.0 now, but I cannot find 2 files “dvdplayer” and “”. When I went to the QNX website, I saw the sample about the dvdplayer, it make me know how the “” is used. However, this sample is only belong to the documentation for Momentics 6.1, I could not find it in any other sections (in 6.2.1 and 6.3)

  1. Are there the “dvdplayer” and “” in Multimedia TDK for QNX 6.3?
  2. I found in Multimedia TDK for QNX 6.3 some executable files : “mpegvideo”, “mpegsystem”. Are they the replacement for “dvdplayer” and “”?

I have never played with this TDK. If you have it then it sure comes with some support so why not ask QSS directly.

Dear mario,
We had a license of Multimedia TDK for QNX 6.3.
We have downloaded the file name and installed the TDK on my QNX 6.3.0 machine already. Unfortunately, I didn’t find the documentation of the TDK out.
The Multimedia TDK does not include DVD authentication and playback modules.
Please kindly help us out about the documentation and guidance where We really need documentation for DVD player software developing.

thanks and best regards,