ntp 4.2.0 for QNX 6.2.1


I needed a way to set the real-time clock on my machine from an atomic clock, and since I couldn’t find ntpdate I just went ahead and ported the whole ntp thing.

QNX 6.3 comes with ntp already, (but I’m stuck with 6.2.1 for the time being) so if you’re running 6.2.x too and need an ntp client or server, here’s one.

Everything should be there and functional except for one of the radio clock modules, neoclock4x, which I had to remove or it wouldn’t compile.

You can download it here: ntp420qnx.tar.gz (1206177 bytes).



Thanks a lot for the compiled ntp source code.

I’m also using QNX 6.2.1, and I have tried the code you posted. But I didn’t succeed, :frowning: .

Could you tell me if I need to configure something else in the system?

I have tried a ntp server in another machine (windows 2000) and the ntp client in another QNX machine (different from the one I’m running the ntp client).


Hi Jose,

Sorry for the late reply, I completely forgot that I ported ntp and the forum header didn’t get my attention until now :confused:

I must have done this while being very tired (or sleep-programming) as even my own readme doesn’t ring a bell.

Anyway, it works here, simply using the command line “ntpdate domain_or_ip”, e.g:
‘ntpdate’ or ‘ntpdate time.ucsd.edu’

If your ntp server follows the rfc 1305 specs, uses port 123 and your network/firewall isn’t blocking that port, it should work.
Maybe your server uses an older version of the protocol, try -o1 to -o3 to see if that helps.
If you can reach the internet, try one of the servers above or swisstime.ethz.ch they all work.


Hi Alex,

Thanks for the answer, and don’t worry for being late, ;)

I’m trying to connect the ntp client (QNX machine) to a ntp server (Windows 2000 machine) through a LAN (Ethernet). The machines are
visible, and I must admit I was suspicious of the ntp server. I must work on it deeper, of course.

On the other hand, did you change lot of things to compile it under QNX 6.2.1?

My idea is to get the source code, and change it a little to set the time in another way. Of course, I’ll add the license statement.

Many thanks

I tried all options. but I couldn’t connect to my W2kSP4 time server. I downloaded the latest release of NTP for Win32 and installed it. After that ntpdate myserver
became rasing memory fault.
I didn’t succeed with the server configuration, so can you help me? I use QNX 6.2.1B PE.


I am using QNX6.3, but wondering that I was not able to find the NTP in the package. But as I understood from the communication that it will be the integral part of the QNX6.3.

Could you please let me know how to check for the availability of the NTP in the package.

Thanks in Advance,

Best Regards,

Yeah, I can see those files on my QNX 6.3


Thanks a lot.


Set Your Computer Clock Via the Internet NIST Internet Time Service (ITS) … The 32-bit binary format can represent times over a span of about 136 years. Try it!

70-236 questions
650-393 questions
650-251 questions