Booting QNX 6.3 from Compact Flash


I am relatively new to QNX, and am involved in porting a QNX 4.25 system to QNX 6.3. The existing hardware boots QNX 4.25 from a compact flash card. The compact flash is attached to a pentium 3 CPU.

How do I format a compact flash card such that it will boot QNX Neutrino? Is it possible to format the compact flash using a Windows PC with a usb cf-writer?

Any help is appreciated.


I assume you have down loaded the approprete package? If so,you “should” be able to install to the path of the flash device and QNX installer will “format” it.Of course it has to be mounted by your os before the install.Is this on Windows?


I believe the tools you want to use are the flash file system TDK and the flashctl tool. The TDK will provide you with the drivers and the tools you need to see the flash. flashctl will be useful to fomat the device once you can access it… The QNX docs on flashctl will provide you the details you need (look under the Utilities Reference…

Hope this helps!

If the system boot from QNX4 chances are the Comact Flash as an IDE interface. That means the compact flash can be treated just like a HD. Under QNX4 is there a Fsys.eide/Fsys.ide/Fsys.ata running or devf*?

Search for ‘CF’ and ‘boot’ within People like evanh, mario, rick and others explain us all how to do the trick. They also explained some potential pitfalls.

Using devb-umass, dinit and fdisk will do the trick.

enode: the poster was talking about compact flash card, so if I am not mistaking, flashctl can’t be used.


I read all of the other posts, but I am still not having any luck. Running dinit from the Windows machine on the USB CF reader reports that the device is too small. The card is a 128MByte CF card, so I’m not sure what the problem is.

As a second approach, I am trying to make the CF card bootable by using a Neutrino host. When I run the io-usb -duhci command, I can see the /dev/io-usb/io-usb is created. Running usb -vvv shows that the device is there, and that the interface class is 0x08 (Mass Storage), the Subclass is 0x06 (SCSI), and that the protocol is 0x50.

When I run devb-umass cam pnp, the command returns the string “PATH=0 - QNX USB Storage”, but no new device is created at /dev/hd*, where * should be a “1” on my system (/dev/hd0 is hard drive).

All of the other commands (fdisk, etc.) expect the device to be created at /dev/hd*

I have read that others had this problem, but I’m not sure what the resolution is. Is it a USB CF reader manufacturer issue? I have tried two different USB CF drives, and both behave the same way.


I can now access the USB CF reader. QNX sent me a new devb-umass driver, and now the /dev/hd* device gets created.

Next step is making a bootable image.

Thanks for all the inputs.

Hi, jmelchio. For now, I encounter the same problem .
I can get the information by using “usb -vvv” command after plugging the CF card reader in USB port , but I get no device in folder /dev.
So I think, maybe I can get a solution from you. Can you send me the new devb-umass driver?
Thank you in advance.

Oh, I am sorry. I forgot giving you my email,
I appreciate your help.