data removed

i need some help in figuring out, why during a backup from my main
server (running qnx 4.24 )to a hard drive on another system(backup system
running QNX 4.24) most of the
data on my server got deleted

My setup up is I have a main server running QNX 4.24 with a Perceptive
Solutions, Inc PCI-2000A Raid Controller with RAID 5, P4B motherboard
with 2.0 Gig CPU

The backup system has an adaptec 2940, P4 with a 2.0 Gig CPU. We were
using aha7scsi SCSI driver. The system has two hard drives. One we
backup onto with to which is mounted as /DATABKUP(its a 4 gig
drive) The other hard drive gets a copy of the data when changes are
made on the main servers hard drive through a custom written program.

For a few days ago “/bin/Fsys terminated (SIGSEGV)” has been displayed on
the backup system. When we try to access its drive we then see that
they are not accessible. We then reboot the backup server and all is
good most of the times we don’t see that message again for a day or so

However yestesday when a manual backup was being run at the slave
server(happens each morning) to its hard drive, machine language
started showing up where normally file names would. A message was
displayed on the backup system saying //1/rm terminated (SIGSEGV)". At
first I thought the backup’s systems adaptor driver had failed, so I
rebooted it, I then realised that the main server could was also stuck
and I then rebooted it. The main server come up and after the os
showed the raid controller(after sinit) it displayed a message no such
file or directory. We then tried to boot off of the backup server
which displayed the same error message (important os boot files were

We were able to find another hard drive and boot up off of it however
what we observed was that most of the diretories on the main server’s
hard disk(RAID) no longer exist. The disk on the slave server that
accept the automatic copy looked like the servers hard drive. The
hard drive that recives the manual backup had files on it but many of
them were corrupt(a ls showed machine lanuage where files should be).
I figure that the driver for the scsi card on the slave died but the
rest I can’t explain. Can anyone offer me some insight? After the
backup we also run chkfsys and have not seen any errors in months.
The manual backup script is listed below:

The backup script:
echo Starting backup to Hard Drive.

if test -d /DATABKUP/home.old
mv /DATABKUP/home.old /DATABKUP/home.rm

if test -d /DATABKUP/home
mv /DATABKUP/home /DATABKUP/home.old

if test -d /DATABKUP/home.rm
rm -Rf /DATABKUP/home.rm &

if test -d /home
cp -Rvp /home /DATABKUP/home

echo Done.
freeze -cdz /etc/logo.F