Vmail - problems getting news working

I’ve just installed QNX on my PC. It’s like Unix -
only better!

I’ve had some problems with vmail/package system…

After I first installed I was connected and browsing the
web with Voyager in 20 minutes. Including sorting out
and connecting the external modem. Configuration work
was minimal. I’m impressed.

I set up e-mail on one of my unused e-mail accounts
in vmail and sent some tests and that worked too.

I tried the package manager and Doom downloaded
and ran fine.

(I’m still root at this point; I assume it’s correct to be
root for installing packages? Unless I really want them
accessible to one user.)

Then I decided to load the 6.1 update. After re-writing my
startup floppy and rebooting, vmail seems to have gone
missing. I didn’t ask it to remove anything- just patch up
what was there. It concerns me things can be lost when
loading updates. I seem to have an “update” that is a
“downgrade” - “mailer” doesn’t do news; and won’t
remove messages from a POP. Voyager mail (vmail)
does what I want. The update did make the sound
start working though.

Anyhow, vmail is an unchecked package option so I
fetched it; and manually added it back into the shelf.
Hmm - why did my shelf get meddled with? I thought
that was personal workspace, not controlled by the

I got my mail in vmail working as root but:

  1. as root, I couldn’t add news-servers and it asks for
    a username and login for inn.qnx.com - why?

  2. When I click “help” in vmail, the referenced
    html file is missing. How do I get it? Is there
    something wrong in the package depencencies
    stuff if it fails to install related documentation?

  3. I quit root and went in as user. I then got mail
    working as user. And I got into my ISP’s news
    server too. But when I quit vmail it lost all of the
    settings the next time I started it. Why can’t
    it store settings - where should it be storing
    settings and how do I check where it’s trying
    to store settings?

    A big annoyance is that the video picture in QNX
    is a slightly different position & size to when I’m in
    Windows. This meant that I couldn’t see the launch
    button in the bottom left corner when I first started
    QNX as it was off the visible area of the monitor.
    It took a while to twig I couldn’t see all of the QNX
    desktop. I have to keep re-adjusting the monitor.
    Monitor on-screen menus not being very friendly
    or desgned for frequent use.

I’m using identical screen resolutions (1280x1024,
16-bit colour, 75Hz) in both OS as this is what my
hardware works best at (19" NEC ViewSonic
monitor, Nvidia Riva TNT2 M64).

How do I tweak the active screen position in QNX
to match Windows ME? Does everyone who uses
dual-OS installations get this problem?

As I understand QNX supports Java2; how do I get
the JDK (the development environment?) Is it
possible to use Sun’s Forte for Java IDE under
QNX, as it is, itself, entirely written in java? Will I
get the GNU java compiler if I install the GNU

Any clues on these issues would help. Thanks, Ant