Can't Open Telnet Session to Target

Qnx 6.21 running on winXP, downloading to x86 target.

In my boot script I include tftp and telnet:

--------- Slice from script… ---------

.script = {

ifconfig en0
qconn &




The target boots up ok, I can run an app from the IDE (downloads via ethernet) and ping works, so I know tcp/ip is set up ok.

Problem is:
When I try to telnet from a telnet plugin (X-Parrots) or hyperterm, to the target, I am always denied access.

From IDE Plugin, telnet session replies:
"Could not open connection
(; Connection refused: connect)

Is there something I need to do in the script to enable telnet from the target?

Any suggestions would be appreciated.

You need inetd, inetd.conf, telnetd

you need inetd and inetd.conf,

Thanks for the information. I’ve been reading and trying to fix my problem from your response.

I added inetd to the startup script and can see it executing after the target is running.
I also added the target\qnx6\etc\inetd.conf, telnetd and tftpd to the list of services at the end of the my build script.

To make sure I understand correctly:
inetd runs in the background waiting for a request for services.
inetd.conf contains the configuration params for each service.
telnetd and tftpd are the services called by inetd if one is requested (incoming requests).
Telnet and tftp are clients that are used to request the service from someone else (outgoing requests).

I still get the same errors when I try to telnet in from the IDE plugin or hyperterminal.
Any further suggestions? - thanks.

Yes you got it right

Start inetd with -d to see what is is doing. You may needs /etc/services

  1. I don’t know Windows XP Hyperterminal could do “telnet”.

  2. The “plugin” you are trying, may hiting a Java Security issue.

Try XP native telent (Start → Run → Telnet) instead see if you can get through.

I tried XP native telnet (thanks - I didn’t know it existed), and I am getting an error response. I’m certain the IP address is valid, I use it in the IDE to launch the debug session.
“Connecting To…Could not open connection to the host, on port 23: Connect failed”

I also noticed from a console (serial connection) that the inetd process is in SIGSUSPEND state. Shoudn’t that be in a WAIT state?

Any thoughts?

Thanks for the help you’ve already provided Xtang and Mario - I appreciate it.

  1. check the “telnet …” line in /etc/inetd.conf is “uncomment” (no # at beginning)
  2. check if “inetd” IS running
  3. If still not work, put “netstat” on target, try post the output of “netstat -ni”, “netstat -nr”, “netstat -na”

SIGSUSPEND is ok, I believe inetd is doing “select()”.