Matrox Millenium II not detected

Hi!

Just installed QNX RtP, but the system doesn’t detect my Matrox
Millenium II and I have to run Photon with Vesa@60Hz … :frowning:

Any suggestions?

\

Alexander C. Hubmann
Student of Telematics, Technical University of Graz - Austria
http://xpert.n3.net

In message <lel4ts4qlo6bk8obml5cp58253nsis3vie@4ax.com>, Alexander C. Hubmann
wrote:

On 27 Sep 2000 19:49:32 GMT, Michael Van Reenen <> mvr@qnx.com> > wrote:

Could you post the output of pci -v so we can
see the device id of the graphics card?

Class = Display (VGA)
Vendor ID = 102bh, Matrox
Device ID = 51bh, Millenium II
PCI index = 0h
Class Codes = 030000h
Revision ID = 0h
Bus number = 0
Device number = 10
Function num = 0
Status Reg = 280h
Command Reg = 7h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 20h
Cache Line Size= 0h
Mem Address = e7000000h prefetchable 32bit length 16777216 enabled
Mem Address = e6000000h 32bit length 16384 enabled
Mem Address = e5800000h 32bit length 8388608 enabled
Subsystem Vendor ID = 102bh
Subsystem ID = 1100h
Expansion ROM = ffef0000h length 65536 disabled
Max Lat = 0ns
Min Gnt = 0ns
PCI Int Pin = INT A
Interrupt line = 9


And I discovered, that /usr/photon/bin/device.map doesn’t include the
devg-matrox.so (Millenium/MilleniumII/G100), but only the
devg-matroxg.so (G200/G400).

Hey, that’s interesting. My device.map doesn’t include
the devg-tnt.so, and I’m having the same problem with
my RivaTNT. Can anyone explain this?

Could you post the output of pci -v so we can
see the device id of the graphics card?

Alexander C. Hubmann <LonesomeDreamer@gmx.net> wrote:

Hi!

Just installed QNX RtP, but the system doesn’t detect my Matrox
Millenium II and I have to run Photon with Vesa@60Hz … > :frowning:

Any suggestions?


Alexander C. Hubmann
Student of Telematics, Technical University of Graz - Austria
http://xpert.n3.net

On 27 Sep 2000 19:49:32 GMT, Michael Van Reenen <mvr@qnx.com> wrote:

Could you post the output of pci -v so we can
see the device id of the graphics card?

Class = Display (VGA)
Vendor ID = 102bh, Matrox
Device ID = 51bh, Millenium II
PCI index = 0h
Class Codes = 030000h
Revision ID = 0h
Bus number = 0
Device number = 10
Function num = 0
Status Reg = 280h
Command Reg = 7h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 20h
Cache Line Size= 0h
Mem Address = e7000000h prefetchable 32bit length 16777216 enabled
Mem Address = e6000000h 32bit length 16384 enabled
Mem Address = e5800000h 32bit length 8388608 enabled
Subsystem Vendor ID = 102bh
Subsystem ID = 1100h
Expansion ROM = ffef0000h length 65536 disabled
Max Lat = 0ns
Min Gnt = 0ns
PCI Int Pin = INT A
Interrupt line = 9


And I discovered, that /usr/photon/bin/device.map doesn’t include the
devg-matrox.so (Millenium/MilleniumII/G100), but only the
devg-matroxg.so (G200/G400).

Hope that helps …


Alexander C. Hubmann
Student of Telematics, Technical University of Graz - Austria
http://xpert.n3.net

The Device ID for your card is missing in the graphics enumeration file,
/etc/system/enum/devices/graphics

If you edit this file you will find a number of entries for Matrox Cards. If
you copy one of the lines for the devg-matrox.so and change the device ID to
051b, then reboot your system the card should be detected. Let us know if this
works and we will fix the file for the next release/patch.
Thanks


Alexander C. Hubmann <LonesomeDreamer@gmx.net> wrote:

On 27 Sep 2000 19:49:32 GMT, Michael Van Reenen <> mvr@qnx.com> > wrote:

Could you post the output of pci -v so we can
see the device id of the graphics card?

Class = Display (VGA)
Vendor ID = 102bh, Matrox
Device ID = 51bh, Millenium II
PCI index = 0h
Class Codes = 030000h
Revision ID = 0h
Bus number = 0
Device number = 10
Function num = 0
Status Reg = 280h
Command Reg = 7h
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 20h
Cache Line Size= 0h
Mem Address = e7000000h prefetchable 32bit length 16777216 enabled
Mem Address = e6000000h 32bit length 16384 enabled
Mem Address = e5800000h 32bit length 8388608 enabled
Subsystem Vendor ID = 102bh
Subsystem ID = 1100h
Expansion ROM = ffef0000h length 65536 disabled
Max Lat = 0ns
Min Gnt = 0ns
PCI Int Pin = INT A
Interrupt line = 9



And I discovered, that /usr/photon/bin/device.map doesn’t include the
devg-matrox.so (Millenium/MilleniumII/G100), but only the
devg-matroxg.so (G200/G400).

Hope that helps …


Alexander C. Hubmann
Student of Telematics, Technical University of Graz - Austria
http://xpert.n3.net

On 27 Sep 2000 20:53:56 GMT, Michael Van Reenen <mvr@qnx.com> wrote:

The Device ID for your card is missing in the graphics enumeration file,
/etc/system/enum/devices/graphics

If you edit this file you will find a number of entries for Matrox Cards. If
you copy one of the lines for the devg-matrox.so and change the device ID to
051b, then reboot your system the card should be detected. Let us know if this
works and we will fix the file for the next release/patch.
Thanks

Hmmm … something went terribly wrong … I copied the line with the
Matrox Millenium II (think it was the line with the device ID 057f),
changed the device ID to 051b and rebooted …

And now I get thousands of lines saying:

File /etc/system/enum/devices/graphics(215): unexpected token ‘’

right after bootup …

I’ll reinstall QNX and try again … :wink:

\

Alexander C. Hubmann
Telematik-Student, TU Graz
http://xpert.n3.net
http://telematik.n3.net

Alexander C. Hubmann <LonesomeDreamer@gmx.net> wrote:

And I discovered, that /usr/photon/bin/device.map doesn’t include the
devg-matrox.so (Millenium/MilleniumII/G100), but only the
devg-matroxg.so (G200/G400).

device.map is no longer used. We only used it when we were leading the
way to the new device enumeration stuff.

The lists of supported `stuff’ are kept in files in
/etc/system/enum/devices/*

The graphics cards are in graphics

I guess you discovered this in kind of a bad way. I suggest that you
disturbed something in the formatting when you copied that line.

“Alexander C. Hubmann” wrote:

Hmmm … something went terribly wrong … I copied the line with the
Matrox Millenium II (think it was the line with the device ID 057f),
changed the device ID to 051b and rebooted …

And now I get thousands of lines saying:

File /etc/system/enum/devices/graphics(215): unexpected token ‘’

right after bootup …

I’ll reinstall QNX and try again … > :wink:

Were the issues with the Matrox Millennium II ever resolved? I am having the
same problem.

Thanks,
ccg

Chad Glendenin <ccg_spam@nospamyahoo.com> wrote:

“Alexander C. Hubmann” wrote:

Hmmm … something went terribly wrong … I copied the line with the
Matrox Millenium II (think it was the line with the device ID 057f),
changed the device ID to 051b and rebooted …

And now I get thousands of lines saying:

File /etc/system/enum/devices/graphics(215): unexpected token ‘’

right after bootup …

I’ll reinstall QNX and try again … > :wink:

Were the issues with the Matrox Millennium II ever resolved? I am having the
same problem.

Did you edit your /etc/system/enum/devices/graphics file to contain an entry with
your cards’ device ID? We will be adding it to our file for the next patch, but do
not have a card with the ID 0x051b to try.



Thanks,
ccg

Michael Van Reenen wrote:

Chad Glendenin <> ccg_spam@nospamyahoo.com> > wrote:

Were the issues with the Matrox Millennium II ever resolved? I am having the
same problem.

Did you edit your /etc/system/enum/devices/graphics file to contain an entry with
your cards’ device ID? We will be adding it to our file for the next patch, but do
not have a card with the ID 0x051b to try.

Yes, I did, and I had the same problem as the previous poster. When I
boot, it goes into an infinite loop printing this out:

File /etc/system/enum/devices/graphics(215): unexpected token ‘’

Any idea what causes this? All I did was open the text file, find the
Matrox section, copy the last device id line above the Matrox device
driver line, change the id to 051b, and reboot.

Since it does this in the early stages of booting, I can’t get in to
change it. If I reinstalled QNX, could I manually set the device id
for the graphics device driver from the advanced settings input box in
the display settings control panel?

Chad

Chad Glendenin <ccg_spam@nospamyahoo.com> wrote:

Any idea what causes this? All I did was open the text file, find the
Matrox section, copy the last device id line above the Matrox device
driver line, change the id to 051b, and reboot.

Do you mind if I ask how you editted the file? Did you use vi, ped, jed
or some other editor? Did you manually create a backup of the file before
you editted it?

Since it does this in the early stages of booting, I can’t get in to
change it. If I reinstalled QNX, could I manually set the device id
for the graphics device driver from the advanced settings input box in
the display settings control panel?

No. It needs to be in the enum files before you will even have an entry to
edit in the advanced config dialog.

If you use ped to edit system files you must turn off the “styled text”
checkbox in the ped preferences.
Richard.

pete@qnx.com wrote:

Chad Glendenin <> ccg_spam@yahoo.com> > wrote:

Any idea what causes this? All I did was open the text file, find the
Matrox section, copy the last device id line above the Matrox device
driver line, change the id to 051b, and reboot.

Do you mind if I ask how you editted the file? Did you use vi, ped, jed
or some other editor? Did you manually create a backup of the file before
you editted it?

It was either vi or the graphical text editor that comes with the GUI;
I can’t remember which. I did not create a backup file. Is there a
correct way to do this that would prevented the error?

ccg

Chad Glendenin <ccg_spam@yahoo.com> wrote:

pete@qnx.com > wrote:

It was either vi or the graphical text editor that comes with the GUI;
I can’t remember which. I did not create a backup file. Is there a
correct way to do this that would prevented the error?

If you used vi, you wouldn’t have had the problem I was talking about.

If you used `ped’ (the graphical editor), by default it saves some garbage
info in the file, and that is probably what caused your problem.

In the next patch, ped will not by default save this junk in the file, and
the enumeration stuff will have some smarts in it to prevent it from loading
backup files that happen to be in the enum directory.

You are right. I must have used ped initially, because when I
reinstalled QNX, I used vi to edit the file, and now the system boots
and the Matrox Millennium II is detected.

Unfortunately, it still won’t allow anything above 60 Hz for a refresh
rate. At least the display is accelerated now. Is there anything we
can do to get higher refresh rates? I still don’t think it’s really
usable, because the 60Hz refresh rate gives me serious eye strain.

Thanks again,
ccg


pete@qnx.com wrote:

Chad Glendenin <> ccg_spam@yahoo.com> > wrote:
pete@qnx.com > wrote:

It was either vi or the graphical text editor that comes with the GUI;
I can’t remember which. I did not create a backup file. Is there a
correct way to do this that would prevented the error?

If you used vi, you wouldn’t have had the problem I was talking about.

If you used `ped’ (the graphical editor), by default it saves some garbage
info in the file, and that is probably what caused your problem.

In the next patch, ped will not by default save this junk in the file, and
the enumeration stuff will have some smarts in it to prevent it from loading
backup files that happen to be in the enum directory.

Chad Glendenin <ccg_spam@yahoo.com> wrote:

You are right. I must have used ped initially, because when I
reinstalled QNX, I used vi to edit the file, and now the system boots
and the Matrox Millennium II is detected.

Unfortunately, it still won’t allow anything above 60 Hz for a refresh
rate. At least the display is accelerated now. Is there anything we
can do to get higher refresh rates? I still don’t think it’s really
usable, because the 60Hz refresh rate gives me serious eye strain.

Thanks again,
ccg

Unfortunately there is no refresh rate support for older Matrox cards. The
only Matrox cards we support refresh rates on are the G200 and G400 chipsets.


pete@qnx.com > wrote:

Chad Glendenin <> ccg_spam@yahoo.com> > wrote:
pete@qnx.com > wrote:

It was either vi or the graphical text editor that comes with the GUI;
I can’t remember which. I did not create a backup file. Is there a
correct way to do this that would prevented the error?

If you used vi, you wouldn’t have had the problem I was talking about.

If you used `ped’ (the graphical editor), by default it saves some garbage
info in the file, and that is probably what caused your problem.

In the next patch, ped will not by default save this junk in the file, and
the enumeration stuff will have some smarts in it to prevent it from loading
backup files that happen to be in the enum directory.

Michael Van Reenen wrote:

Unfortunately there is no refresh rate support for older Matrox cards. The
only Matrox cards we support refresh rates on are the G200 and G400 chipsets.

Is there any hope for future releases? I don’t want see Photon on 60 Hz,
too :frowning:((.

SB

Sebastian Bähr <sbaehr@onlinehome.de> wrote:

Michael Van Reenen wrote:

Unfortunately there is no refresh rate support for older Matrox cards. The
only Matrox cards we support refresh rates on are the G200 and G400 .


Is there any hope for future releases? I don’t want see Photon on 60 Hz,
too > :frowning:> ((.

Probably not. It’s not a priority right now, especially since we do
support refresh rates on the newet Matrox cards.

SB