installation problem on laptop fujitsu-siemens amilo L6825

I’m trying to install qnx 6.3.0 on my machine and i seems i have a problem
i get an error message “Could not allocate 1151194144 bytes” when creting partition

i have 2GB unalocated space not on an extended partition
and i choosed not to use the bootloader from qnx(i already have grub configured)
so fails to create any partion and abords installation.
i’ve tryed with dma disabled and get the same results
can anyone help me please??

one more thing… i have a hdd seagate momentus ST94011A (i tryed to find it on the supported hardware - and no result)
the thing is i tryed to install earlier a qnx 6.1 and that one … worked out until some other point (i got to see the #sh prompter but unable to start photon)

Probably your partition table is in a state that QNX’s brain dead “fdisk” can’t handle. You can try to use fdisk from linux and do a manual installation of QNX 6.3 as discussed here.

how is LiveCD mode?

isn’t when you boot from cd and choose F2 (Run from CD)?
do i have to do something before running in LiveCD? (beside the manual partitioning) because i get an error message: “Unable to locate devb_rom”



there must be something wrong with your CD. there is NO devb_rom in QNX 6. The closest I can see is devb-ram.

If you can’t even “Run from the CD”, your hardware is not supported.

Are you having more than one CD/DVD drives? Anything special with the RAM?

yes you were right there was “unable to locate devb-ram”
when i enable verbose mode
i get the folowing messages:
Unmounting /fs/cd0-qnxbase.qfs
Remounting /fs/cd0/boot/fs/qnxbase.qfs as /
Remounting complete
Unable to locate devb-ram

i still want to hope that not the hardware is the problem (when i tried an older version of qnx… i was able to get to some sort of point in my instalation … i saw the #sh prompt :stuck_out_tongue:)

my cd drive is AXV CD/DVD-ROM SCSI CdRom Device (and is the only one i have)… could i try an install from a flash card?
have any ideas ?? i reaaly need qnx for school devel :frowning:

i’ve tryed to install 6.3 on vmware and
after the allert

i get the same message. “Could not allocate… etc” and i followed all the steps described in

i managet to install it after all, by using a virtual drive and mounting the iso image directly in vmware (i guess the problem was my cdrom)