QNX-RTP failed to boot with all safe-mode options and disabl

My QNX-RTP installed under Windows 95 in file-partition crashes during first boot. The last message on ‘verbose’ option is ‘mounting’ a dos filesystem as /fs/hd1-dos
on /dev/hd1t11.1’ Before this it succesfully indicated my HDD’s and CD-ROM and mounted CD-ROM partition. I used both safe-mode option with same result. Maybe
the reason of this trouble is Linux partitions on the same drive? What can i do to turn off mountind DOS-partitons?
boot options:
dma-disable boot-mode
all enumerators and additional drivers (F11 & F12 menus) disabled
safe-mode options: F4 F5 F6(verbose-mode)

My hardware:
K6-200, VIA-VX-pro+ motherboard, 64 Megs of memory, two Seagate HDDs (2,1 & 6,4Megs each), Cirrus Logic 5446 2megs video, ISA ess1868 sound-card,
MITSUMI FX-240b CD-ROM. Its all…

This is what linux fdisk gives to me for /dev/hda:
Partitions Boot Start End Blocks ID System
/dev/hda1 1 511 1030144+ b Win95 FAT32 ← Disk C: under Windows
/dev/hda2 955 1022 137088 5 Extended
/dev/hda4 + 512 954 893088 83 Linux ext2
/dev/hda5 955 962 16096+ 1 FAT12 ← Disk D: under Windows
/dev/hda6 963 1022 120928+ 82 Linux Swap

wich of this partitions became /fs/hd1-dos?

(I have also problems with english in /dev/head - not for this conference)
Thanks all,
Vladimir Stus’