cant start OpenSSH-Deamon, "PRNG is not seeded"

Hi everyone,

I want to start the sshd right from the start using rc.local. But allthough random is started and /dev/random (as well as /dev/urandom) are there the sshd doesnt start (saying PRNG is not seeded).
It helps to sleep about 5 sec. But this isnt very nice.
So here is the question: how can I distinguish whether PRNG is ready to sart sshd.
Question no.2: Is there a way to sleep parallel to the boot process (means that the machine keeps running the boot-scripts, while sshd waits for PRNG)



Not sure but isn’t sshd usually started by inetd?

If you disable insecure SSH-1 protocol in the OpenSSH configuration - it is indeed far better to start sshd from inetd. The enthropy will be available by the time someone attempts to connect. You’ll save machine’s resources by not having extra daemons running around.
(SSH-1 is much faster if it is not in inetd mode - it depends on having the server key generated. If you run it from the inetd - it will generate a new key for each connection, which is slow. SSH-2 does not need to generate keys this way and therefore is not penalized if run from the inetd.)

This has been discussed in details at

In summary, there are nothing you can “waitfor”. The only other way is to hook up “random” with more sources so that you don’t have to “sleep” and wait.