Memory Pb - QNX RTP

I still have a memory problem (only 16Mb detected instead of 16+64Mb…) on
my Conpaq Armada 1590.

I ONLY install Qnx RTP on this computer so :

  • no way to modify config.sys …(readme.txt)
    and computer setup doesn’t allow me to disable memory hole…

If you have a solution/idea, tell me PLEASE
(i will have to use a MS product instead of QNX :-[)

Thanks

GNI

On Tue, 22 May 2001 21:05:51 +0200, “GNI”
<guillaume_nicole@hotmail.com> wrote:

I still have a memory problem (only 16Mb detected instead of 16+64Mb…) on
my Conpaq Armada 1590.

I ONLY install Qnx RTP on this computer so :

  • no way to modify config.sys …(readme.txt)
    and computer setup doesn’t allow me to disable memory hole…

If you have a solution/idea, tell me PLEASE
(i will have to use a MS product instead of QNX :-[)

You could try to customize the boot image. Can you

install over 16MB? Then add a ‘-M start,size’ parameter to the
‘startup-bios’ call in /boot/build/qnxbase*.build file, and rebuild
the image with mkifs. Better yet, install it as .alboot.

ako

Thanks

GNI

I have try to add in qnxbase*.build
startup-bios -s 64k -M 0,80000k

and when i rebuild with
a) mkifs *.build only qnxbasedma.build changes
b) mkifs qnxbase.build … i obtain strange caracters on screen

(i have try to copy qnxbasedma.build into qnxbasedma.ifs )
→ No change on memory detection

Any mistake in the way i do this ???

GNI


“Andrzej Kocon” <ako@box43.gnet.pl> a écrit dans le message news:
3b122212.326645@inn.qnx.com

On Tue, 22 May 2001 21:05:51 +0200, “GNI”
guillaume_nicole@hotmail.com> > wrote:

I still have a memory problem (only 16Mb detected instead of 16+64Mb…)
on
my Conpaq Armada 1590.

I ONLY install Qnx RTP on this computer so :

  • no way to modify config.sys …(readme.txt)
    and computer setup doesn’t allow me to disable memory hole…

If you have a solution/idea, tell me PLEASE
(i will have to use a MS product instead of QNX :-[)

You could try to customize the boot image. Can you
install over 16MB? Then add a ‘-M start,size’ parameter to the
‘startup-bios’ call in /boot/build/qnxbase*.build file, and rebuild
the image with mkifs. Better yet, install it as .alboot.

ako

Thanks

GNI

On Wed, 30 May 2001 20:28:57 +0200, “GNI”
<guillaume_nicole@hotmail.com> wrote:

I’m sorry for too general a response.

Edit qnxbase.build or qnxbasedma.build, depending
on whether you want the system to support DMA.
Or copy one of these files to your own build file and
edit it (the name of the file may be arbitrary). Make
a copy of /.boot and /.altboot files to a safe place.
Also, have you made a bootable diskette (just in case)?
Now rebuild the boot image:

mkifs my.build.file /.boot
or
mkifs my.build.file /.altboot

With the second example, you should be able to boot
the ‘original’ image (from /.boot) or the altered one
(from /.altboot, just press Esc when prompted at the
beginning of the startup process).

Maybe you will have to specify separate
segment(s) in the -M parameter. Can you run photon
and the helpviewer with 16MB, or on another installation?

ako

I have try to add in qnxbase*.build
startup-bios -s 64k -M 0,80000k

and when i rebuild with
a) mkifs *.build only qnxbasedma.build changes
b) mkifs qnxbase.build … i obtain strange caracters on screen

(i have try to copy qnxbasedma.build into qnxbasedma.ifs )
→ No change on memory detection

Any mistake in the way i do this ???

GNI


“Andrzej Kocon” <> ako@box43.gnet.pl> > a écrit dans le message news:
3b122212.326645@inn.qnx.com> …
On Tue, 22 May 2001 21:05:51 +0200, “GNI”
guillaume_nicole@hotmail.com> > wrote:

I still have a memory problem (only 16Mb detected instead of 16+64Mb…)
on
my Conpaq Armada 1590.

I ONLY install Qnx RTP on this computer so :

  • no way to modify config.sys …(readme.txt)
    and computer setup doesn’t allow me to disable memory hole…

If you have a solution/idea, tell me PLEASE
(i will have to use a MS product instead of QNX :-[)

You could try to customize the boot image. Can you
install over 16MB? Then add a ‘-M start,size’ parameter to the
‘startup-bios’ call in /boot/build/qnxbase*.build file, and rebuild
the image with mkifs. Better yet, install it as .alboot.

ako

Thanks

GNI

\

I am having the same problem, Compaq Armada 7330, qnx rtp 6.1 on it’s own
partition.

I have copied qnxbase.build to knote.build and added the following to the
startup-bios line so that it reads:

startup-bios -s64k -M 0x01000000,58M,1 -M 0x04800000,58M,1 -M
0xffff0000,132M,1

I did:
mkifs knote.build /.altboot

and rebooted and hit the esc to boot /.altboot

When I login and run pidin in I still get 15MB memory:

CPU:X86 Processor:1 FreeMem:7212Kb/16Mb BootTime:Apr 07 15:35:41 pdt 2002
Processor1: 586 Pentium/MMX Stepping 4 150Mhz FPU

Have I done something wrong? I got the specs for the -M from a page on
compaq.com for my system.

–Keith
“Andrzej Kocon” <ako@box43.gnet.pl> wrote in message
news:3b15f893.1241153@inn.qnx.com

On Wed, 30 May 2001 20:28:57 +0200, “GNI”
guillaume_nicole@hotmail.com> > wrote:

I’m sorry for too general a response.

Edit qnxbase.build or qnxbasedma.build, depending
on whether you want the system to support DMA.
Or copy one of these files to your own build file and
edit it (the name of the file may be arbitrary). Make
a copy of /.boot and /.altboot files to a safe place.
Also, have you made a bootable diskette (just in case)?
Now rebuild the boot image:

mkifs my.build.file /.boot
or
mkifs my.build.file /.altboot

With the second example, you should be able to boot
the ‘original’ image (from /.boot) or the altered one
(from /.altboot, just press Esc when prompted at the
beginning of the startup process).

Maybe you will have to specify separate
segment(s) in the -M parameter. Can you run photon
and the helpviewer with 16MB, or on another installation?

ako

I have try to add in qnxbase*.build
startup-bios -s 64k -M 0,80000k

and when i rebuild with
a) mkifs *.build only qnxbasedma.build changes
b) mkifs qnxbase.build … i obtain strange caracters on screen

(i have try to copy qnxbasedma.build into qnxbasedma.ifs )
→ No change on memory detection

Any mistake in the way i do this ???

GNI


“Andrzej Kocon” <> ako@box43.gnet.pl> > a écrit dans le message news:
3b122212.326645@inn.qnx.com> …
On Tue, 22 May 2001 21:05:51 +0200, “GNI”
guillaume_nicole@hotmail.com> > wrote:

I still have a memory problem (only 16Mb detected instead of
16+64Mb…)
on
my Conpaq Armada 1590.

I ONLY install Qnx RTP on this computer so :

  • no way to modify config.sys …(readme.txt)
    and computer setup doesn’t allow me to disable memory hole…

If you have a solution/idea, tell me PLEASE
(i will have to use a MS product instead of QNX :-[)

You could try to customize the boot image. Can you
install over 16MB? Then add a ‘-M start,size’ parameter to the
‘startup-bios’ call in /boot/build/qnxbase*.build file, and rebuild
the image with mkifs. Better yet, install it as .alboot.

ako

Thanks

GNI


\