QNX 6.3 Installation freezes after boot options message

I am trying to install 6.3 on a double CPU (AMD 2800+) system and the
installation just freezes after:

Hit esc for .altboot ...........
Press the space bar to input boot options or D to disable DMA

message. Even ctrl-alt-del does not work.

I installed 6.1 succesfully to the same machine. Since the next message should be:

Detected EIDE. Scanning for devices

I suspect it may be related to the hard disk but have no idea why 6.1 installs OK but 6.3 fails. BIOS sees the hard disk as the primary master (Western Digital 800JB 80GB) and CD as the secondary master (Lite On CDRW). Just to test the machine I installed Windows XP and it was successful too. I didn’t try it yet with a completely blank HD (either there was the XP partition or 6.1 partition covering all disk, I was planning to delete the whole partition during install). Do you think it is worth a try? There is also an Intel Boot Agent preloaded but I don’t know how to turn it off if that will solve the problem.

Any help/suggestions will be appreciated.

Try pressing ESC when prompted. The altboot doesn’t use DMA, that may be your problem.

maybe your problem i s your hdd
qnx 6.3 have a problems with large hdd (large after 80gb)

Yeah, I tried that but it is still frozen, dots and the other message doesn’t follow but neither anything else happens. The only difference is ctrl-alt-del works this time. Is there a way to disable DMA manually? I searched BIOS setup but didn’t see (or probably didn’t recognize) an option which does that.

I suspect this but I was able to use the same cd with another machine with exactly the same hard drive (single cpu though). I didn’t install it but I was able to run 6.3 from the CD and the step it freezes is before it asks if you want to install it or use it as a live cd. So I conclude that it shouldn’t be the hard disk. Another difference between these two machines is the BIOS though. The BIOS of the one without the problem seems like recognizing all the cylinders, head, sector information (displays them and allows you to change) the other one is more on auto mode but it also recognizes the hard disk correctly.

Ok, this may be a long shot but try disabling or simply disconnecting your A: drive. It may be using DMA. When I was trying to install QNX on VMWare my debugging led me to the a: drive, once I disabled it I could finally run the OS.

This is a VMWare only issue.


  1. did you try press “D” to disable DMA?
  2. did you try press “Space Bar” to input boot options? (one thing that worked for me is F11 and then F2 to disable pnp ISA enumerator, you can try to disable other enumerators).

Yes, I tried those and also disabling the A: drive (thx enode for the suggestion) but they didn’t work. We are in the middle of duplicating our current experiment setup and I was thinking this is a good opportunity for upgrading to 6.3 from 6.1. I’ll try F11 tomorrow. We are using a KVM (keyboard-video-mouse) matrix but I don’t think that is causing the problem, right?

Thank you all for the help. I guess we’ll have to delay 6.3 upgrade for a while.

Did you get a menu of selections for boot options AFTER you press the “Space Bar”?

No. It is just frozen.

Hi pembeci and everybody

I have the same problem, like you on my pc Qnx 6.3 refuse to install.
I don’t think it is because of my hdd, it is only 40 Gb, with only a single 7 Gb partition free.
But my pc is a Dell Precison 530 with one PIV XEON 1.5 Ghz on a Bi-Processor Mother-Board and with 1024 Mo of ECC RDRAM, maybe that is the BIG problem for QNX that could have some trouble with this kind of configuration. :angry: :neutral_face:
" DOMAGE ", i’ll wait for the 6.4 version of QNX, and if the troubles still persist; SNIFF Good BYE QNX and welcome FreeBSD, waiting for a while a new PC Configuration :confused:

:bulb: Maybe on these time when whe can find à Number of Linux Live_CD like Knoppix that work well & that i could test on my PC, i think it could be good for QNX expansion to allow a beter material compatibility.
:open_mouth: :unamused: :wink:
By the way Long Life to QNX NC.