troubles with installing QNX 6.1


I’m aware that QNX hates CD-ROMs connected as a slave without a master, so I reconfigure the connections to the following :
Primary IDE : Master → 4.2 GB Seagate
Slave → none
Secondary IDE : Master → 1.2 GB Quantum
Slave → CD-ROM

Primary IDE : Master → 4.2 GB Seagate
Slave → CD-ROM
Secondary IDE : Master → none
Slave → none

Both yields to “couldn’t find qnxbasedma.ifs” error and reboots, which is the same result if I connect the CD-ROM as a slave without a master.

When rebooted, there are “couldn’t mount …/qnxbase.qfs on…”, but the boot goes on up until it tries to copy qnxbasedma.ifs and fails again. Is it because the
installation detected a QNX partition which doesn’t completed installing previously?

Then I play with pressing space when booting, which brings up a menu. I tried “force partition install”, then the boot failed with crach and an error message of
“doesnt have qnx6.1 filesystem to mount”. I reset the system, but the boot failed again since.

Then I tried to change the partition type of the target partition from dos, from 79 to 21, which is the type before any attempts of QNX install, trying to see if it have
some effects of the “qnxbase.qfs” error. Since now the boot is always halted with the “doesnt have qnx6.1…” error, the boot also crashed.

What the heck I should do???

BTW, the target partition to install is on seagate HDD, with this partition setup (as reported on the 1st installation attempt) :

  1. 1584MB FAT16
  2. 2014MB FAT16, Extended
  3. 462MB ??? ← target
  4. none