Multiple network card problems and crossover cable help

We currently have a multi computer setup. Each computer has two network PCI
cards. One is an Intel based card and has 2 ethernet ports and is handled by
the speedo driver. The other is a DEC 21143 based Phobos P430 Quadport
Adapter with 4 ethernet ports and is handled by the tulip driver.

Now QNX6.1 works perfectly and netmanager detects all 6 ports automatically,
labeling them en0 to en5. The two ports on the Intel card work perfectly,
and we have all the nodes connected to a switch using these cards and it
works great.

However, we can not get the DEC 4 port card working properly. We have used
crossover cables, connecting each DEC card to three other nodes’ individual
DEC card using ethernet crossover cable (the idea is that each node is
connected to a switch to talk to far away nodes, but the three closest nodes
can be talked over faster crossover cables).

We are mostly interested in getting qnet to work over these crossover
cables. A look at the DEC card shows that the “LINK” light never goes on the
ports connected to each other over crossover cables.

We have tried creating an rc.local file, slaying io-net and reloading
component’s individually (as well as separating them with sufficient time by
sleeping a few seconds). This however does not seem to work. We have also
tried some diagnostics (like nicinfo) but cannot seem to find the problem.

Has anyone had a similar situation with this network card, multiple card
setup, or a similar tulip card. I can also post specific command output if
that can help anyone who may have an idea of what’s going wrong. Is there
just something we have not done that will allow qnet to run over crossover
cables (we did try setting 10.0.0.* IP’s but that didn’t seem to help).

Thanks for any help in advance,
M. Herberg

We have determined that the problem is most likely the same “MII No Link”
problem that has plagued a few other users. The tulip driver does not choose
a media type and it cannot be set manually. Consequently the LINK light on
the back of the card never goes on, despite being hooked up through
crossover cable to another card.

Here is the output of nicinfo:

Tulip: DEC 21143 Ethernet Controller
Physical Node ID … 0060F5 08788C
Current Physical Node ID … 0060F5 08788C
Media Rate … 0 kb/s half-duplex UTP
MTU … 1514
Lan … 0
I/O Port Range … 0x6C00 → 0x6C7F
Hardware Interrupt … 0x5
Promiscuous … Disabled
Multicast … Enabled

Total Packets Txd OK … 0
Total Packets Txd Bad … 0
Total Packets Rxd OK … 0
Total Rx Errors … 0

Total Bytes Txd … 624
Total Bytes Rxd … 0

Tx Collision Errors … 0
Tx Collisions Errors (aborted) … 0
Carrier Sense Lost on Tx … 0
FIFO Underruns During Tx … 0
Tx deferred … 0
Out of Window Collisions … 0
FIFO Overruns During Rx … 0
Alignment errors … 0
CRC errors … 0

As one can see, the problem is shown in the “Media Rate”. Does an updated
tulip driver exist, or is there a workaround for this problem?

M. Herberg