Mounting on embedded system

I am new with QNX and have been trying to build a Neutrino build of QNX 6.2. With the help from the users on this form I have been able to get an image up and running and hardware configured correctly. The problem that I am having now is mount other disks. I am lost, I have tried the mount command but the /dev/hd1t77 is missing and when I put /dev/hd1t77 into the image/build the image would not boot. I have removed it and got things running. I have also tried to use the df command, but after I run it, it displays nothing. It runs with no errors, but it seems like nothing is happening.

  I am lost on how to mount other drives to this embedded version and if anyone can please help this lost QNX user.

Thanks for any help.

But, does it mount its own disk? I mean, does the system “see” your hard disks? What does it answer to “ls /dev”?

The system seems to mount the flash file system, and I am able to see directories and files, but the /dev directory is quite limited. It consists of a /ser /con /null and a few others, but there are no /dev/hd#. It seems that the system is not detecting the drives at all. I am not sure if I need to make changes to the build image, or do something once the system is loaded.

Depending on what type “other disk” is, you need to have the right driver running. eg: if it is IDE, you need to include and run devb-eide on your target. This will give you the /dev/hd* , which can then be mounted.

I tried adding the /sbin/devb-eide & and added /sbin/devb-eide to the image and nothing happen, no error, but I still did see anything added to the /dev dir. Also the df command still did not show anything
The other disks are:

1.) 1 GB Compact flash pluged into the Master Primary IDE port (intergrated into the EXB Board)
2.) 4 GB Compact flash on the Master Secondary IDE port.

It looks like I am missing something that would go out and detect drives. I am not sure.

Thanks so much for you help so far.

You have not only to include devb-eide. you have to use it on your buildfile. Take a look at the web noc linked: … -eide.html

Well I think that I am making some head way. I added:
/sbin/devb-eide eide & cache=2m,delwri=2s cd uid=234,gid=120 dos vollabel=ignore &

and after adding a few lib files something happen. Now at boot the screen reads:

Path=0 VIA 82C586A/B
Target=0 lun=0 Direct-Access (0) – SanDisk SDCFH Rev DHB
Path=1 VIA 82C586A/B
Target=1 lun=0 Direct-Access (0) – Sansung CF/ATA Rev 400/

After boot I looked for a /hd director, or any change in the /dev director but nothing changed there, and I still could not mount anything. Now it looks like the system knows they are there but I can still not interact.

Any help that anyone can give me would be great.

It reminds me a few months ago :- >> You have to mount it.

devb-eide blk automount=hd0t79:/,automount=hd0t131:/linux cam quiet eide &

mounts the QNX partition on ‘/’ and a Linux one on the directory ‘/Linux’