npm-qnet.so problem

RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter

Hello Peter,

To use qnet with QNX 6.2 try creating the file “/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the file
exists.

Regards,
Dave B.


“Peter Weber” <pw@dolphin.de> wrote in message
news:aeang9$ihp$1@inn.qnx.com

RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter

“mount -Tio-net npm-qnet.so” works for me (so long as I’m root :wink:

try that instead of putting in the /lib/dll/npm-qnet.so if you want to start
qnet manually (instead of having it always on at boot time, other wise Dave B’s
solution is probably best).

Dave


Apps Support <apps@qnx.com> wrote:

Hello Peter,

To use qnet with QNX 6.2 try creating the file “/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the file
exists.

Regards,
Dave B.



“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter

Thank you for the fast reply Dave.
I tried that before and I see the same error message if I touch a useqnet
file into the config dir.
In RTP61 it works like expected but not in RTP62. Are there any new options
for the npm-qnet module?
In RTP62 I have a new IPv6 interface, may there is another default binding?
With or w/o path to the npm-qnet.so always the same message.
“Apps Support” <apps@qnx.com> schrieb im Newsbeitrag
news:aebacp$4pq$1@nntp.qnx.com

Hello Peter,

To use qnet with QNX 6.2 try creating the file
“/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the
file
exists.

Regards,
Dave B.


“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter
\

Thank you David,
“David Rempel” <drempel@qnx.com> schrieb im Newsbeitrag
news:aecvij$cco$1@nntp.qnx.com

“mount -Tio-net npm-qnet.so” works for me (so long as I’m root > :wink:
Nope, no luck…same problem.

is there any limit for mouted file systems? I have mounted 16 partitions and
2 nfs fs?

try that instead of putting in the /lib/dll/npm-qnet.so if you want to
start
qnet manually (instead of having it always on at boot time, other wise
Dave B’s
solution is probably best).
no luck today > :frowning:

Dave


Apps Support <> apps@qnx.com> > wrote:
Hello Peter,

To use qnet with QNX 6.2 try creating the file
“/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the
file
exists.

Regards,
Dave B.


“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter
\

Peter Weber <pw@dolphin.de> wrote:

Thank you for the fast reply Dave.
I tried that before and I see the same error message if I touch a useqnet
file into the config dir.
In RTP61 it works like expected but not in RTP62. Are there any new options
for the npm-qnet module?
In RTP62 I have a new IPv6 interface, may there is another default binding?
With or w/o path to the npm-qnet.so always the same message.

Could please post:

/bin/uname -a
/usr/sbin/pkgctl /bin/mount
/usr/sbin/pkgctl /lib/dll/npm-qnet.so

and also try:

/bin/mount -Tio-net /lib/dll/npm-qnet.so

-xtang


“Apps Support” <> apps@qnx.com> > schrieb im Newsbeitrag
news:aebacp$4pq$> 1@nntp.qnx.com> …
Hello Peter,

To use qnet with QNX 6.2 try creating the file
“/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the
file
exists.

Regards,
Dave B.


“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter
\

“Xiaodan Tang” <xtang@qnx.com> schrieb im Newsbeitrag
news:aed46i$f7t$1@nntp.qnx.com

Peter Weber <> pw@dolphin.de> > wrote:
Thank you for the fast reply Dave.
I tried that before and I see the same error message if I touch a
useqnet
file into the config dir.
In RTP61 it works like expected but not in RTP62. Are there any new
options
for the npm-qnet module?
In RTP62 I have a new IPv6 interface, may there is another default
binding?
With or w/o path to the npm-qnet.so always the same message.

Could please post:

/bin/uname -a
/usr/sbin/pkgctl /bin/mount
/usr/sbin/pkgctl /lib/dll/npm-qnet.so

and also try:

/bin/mount -Tio-net /lib/dll/npm-qnet.so

-xtang
TIA again, found something ! After installing 6.2 from cd-rom I got a real

mix of packages on my os.
If I boot the box, the boot prompt from 6.1 comes up asking me which drive
to boot from by selecting F1-F4 or the partition1,2,4.
rtp610 was installed on hd0t79 and rtp620 on hd2t79 pressing F1 selects
drive 1, pressing F2 also selects drive 1
F3 reboots the mashine and F4 selects drive 2.
Choosing either F1 or F4 the image loads and comes up with the question:
‘You have more than one .diskroot file which wants to mount at /’
F1 /dev/hd0t79
F2 /dev/hd2t79
Because I installed on the hd2t79 I choose F2
The next question is again:
‘You have more than one .diskroot file which wants to mount at /pkgs/base’
F1 /fs/hd0-qnx4/boot/fs/qnxbase.qfs
F2 /boot/fs/qnxbase.qfs
choosing either F1 or F2 makes no difference I will boot into RTP610

uname -a shows:
QNX venus 6.1.0 2001/08/23-19:38:50edt x86pc x86

/usr/sbin/pkgctl /bin/mount
Localpath: [/bin/mount]
Fullpath: [/pkgs/base/qnx/os/core-2.1.3/x86/bin/mount]
Repository: [/pkgs/base]
Vendor: [qnx/os/core-2.1.3]
Tree: [x86/bin/mount]

— Information from /dev/pkginfo31 —
Localpath: [/lib/dll/npm-qnet.so]
Fullpath: [/pkgs/base/qnx/os/drivers-2.1.3/x86/lib/dll/npm-qnet.so]
Repository: [/pkgs/base]
Vendor: [qnx/os/drivers-2.1.3]
Tree: [x86/lib/dll/npm-qnet.so]
Spilled to: [/var/pkg/spill/x86/lib/dll/npm-qnet.so]

So it seems its still RTP610
but where is my installation of RTP620?

“Apps Support” <> apps@qnx.com> > schrieb im Newsbeitrag
news:aebacp$4pq$> 1@nntp.qnx.com> …
Hello Peter,

To use qnet with QNX 6.2 try creating the file
“/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the
file
exists.

Regards,
Dave B.


“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter

\

G’day Peter


It works if you use

mount -T io-net /lib/dll/npm-qnet.so /

For the some reason putting the slash on the end works.

Matt


“Peter Weber” <pw@dolphin.de> wrote in message
news:aed1ar$bal$1@inn.qnx.com

Thank you David,
“David Rempel” <> drempel@qnx.com> > schrieb im Newsbeitrag
news:aecvij$cco$> 1@nntp.qnx.com> …
“mount -Tio-net npm-qnet.so” works for me (so long as I’m root > :wink:
Nope, no luck…same problem.
is there any limit for mouted file systems? I have mounted 16 partitions
and
2 nfs fs?


try that instead of putting in the /lib/dll/npm-qnet.so if you want to
start
qnet manually (instead of having it always on at boot time, other wise
Dave B’s
solution is probably best).
no luck today > :frowning:

Dave


Apps Support <> apps@qnx.com> > wrote:
Hello Peter,

To use qnet with QNX 6.2 try creating the file
“/etc/system/config/useqnet”.
This file is tested for during the boot process and starts qnet if the
file
exists.

Regards,
Dave B.


“Peter Weber” <> pw@dolphin.de> > wrote in message
news:aeang9$ihp$> 1@inn.qnx.com> …
RTP6.2NC fresh installation into an own partition
I tried to mount the npm-qnet.so to get qnet native network supp.
If I try:
mount -Tio-net /lib/dll/npm-qnet.so
I get:
mount: Can’t mount / (type io-net)
mount: Possible reason: Invalid argument

Tcpip works fine and in the /dev/io-net I have:
en0 ip0 ip_en ipv6_en
On RTP6.1 it was working well on the same hardware
Any ideas?
cheers, Peter

\