Anonymous ftp under QNX| 6.3

Has anyone successfully implemented anonymous ftp under QNX 6.3.
I just need to know if it has been done, so I can go after my problem
with the right attitude.
The problem I’m having is that everything works fine, except that
directories and files do not show up when I do a dir. They are there,
can be cd’d to and downloaded, if you know what they are.
Check out if you like.

This problem was reported to QSS long time ago and was fixed.

Make sure you are running “pipe” as discussed in above thread. If still not working, the fix may not get into QNX 6.3, in which case you might want to check with Sean Boudreau for a fixed version.

I’ll double check, but I’m pretty sure pipe was running.
Thanks, it helps a lot to know I may not be crazy or stupid :slight_smile:.

My problem is now solved. I did not need an update for ftpd.
Rather, I had to put libc in ~ftp/lib. This is curious since I do
not believe that it was needed for 6.2.1.

Thanks for the help.


I just tried to ftp to your server and “dir” still not working.

so I setup an anonymous ftp server myself on my desktop and all works fine, just follow the instructions at … /ftpd.html

In particular, read the text under the section Setting up a restricted ftp subtree :

I’m fairly sure I did all of the above. I checked it again and it is working with
the ls command, but not with the dir command. How curious.
I’ll check your list again and check back when I’m done.

Ok, following your detailed instructions, it works pefectly now.
Thanks again,


Well I’m back again with a new ftp problem. I’ve upgraded my OS to 6.3.2. I refollowed the above instructions just to make sure. Now what happens is that when I ftp anonymously to the system and do an ls, I get a weird error message:

ftp> ls
425 Can’t open passive connection: Address family not supported by protocol fami
227 Entering Passive Mode (198,144,201,135,255,236)
550 /bin/ls: Bad file descriptor.

A disturbing consequence of this error is that pipe has now aborted.

If anyone wants the pipe.core file, just ask and I will provide it for debugging.

Try to ftp to your qnx box from linux or windows.
Let’s see if your problem is the qnx ftp client or qnx ftp server.

Thanks for the suggestion, but the problem is uh, solved. It turned out to be a bug in pipe, for which there is a fix, but to get it I had to download the source. That was actually a lot of fun.