Booting ts-5300 from CF

Hi all,
Having problems booting a TS-5300 ( from a CF.
I tried a few build files and always got the same result: the system hangs at the end of the dotted line.
One of the build files tested was one that I use often for Arcom’s GX-1 and GX-m, modified only for network adapter.
Any idea?
Thank you,

Uhm. Maybe the two machines are connected to different drives, so you have to change the drivers, and probably more things. Buildfiles are customized for each target, so it’s logical it doesn’t work right with another. Try using some ‘display_msg’ before each function, so you can see exactly where it hangs. Attach the buildfile, so we can see if there’s something “suspicious” :- >>

Here is the buildfile, it doesn’t have much specific stuff in it…
The initial display_msg “.script begins” doesn’t even show.
Is there something wrong with the .bootstrap section?
This SBC doesn’t have a video card and redirects a console on COM2. See below for output of the boot process on this port. The cursor keeps on blinking at the end of the dotted line. COM1 never shows a shell prompt.

# Buildfile for Embeddedx86 TS-5300
# Made from #
[virtual=x86,bios +compress] .bootstrap = {
        startup-bios -NTS-5300 -vvv
        PATH=/proc/boot procnto
[+script] .script = {
    display_msg ".script begins"
    devc-ser8250 -b9600 -u1 3f8,4 &
    [+session] PATH=/proc/boot esh &
[type=link] /dev/console=/dev/ser1
[type=link] /usr/lib/
# specify executables that you want to be able
# to run from the shell:  echo, ls, pidin, etc...
# End of build file

Output from the boot process:

|          System BIOS Configuration, (C) 2000 General Software, Inc.          |
| System CPU           : 80486          | Low Memory           : 633KB         |
| Coprocessor          : Enabled        | Extended Memory      : 15MB          |
| Floppy 0 Type        : Not installed  | Serial Ports 1-2     : 03F8 02F8     |
| Floppy 1 Type        : Not installed  | Serial Ports 3-4     :               |
| Ide 0 Type           : 2              | Parallel Ports       : 03BC 0378 0278|
| Ide 1 Type           : 0              | ROM Shadowing        : Enabled       |
| Embedded BIOS Date   : 10/25/04       | Manufacturing Mode   : 02F8 / 38.4K  |
Hit Esc for .altboot........................._

Any insight will be appreciated!

You used my original message :slight_smile:
The problem is the A20 gate. ( There is no keyboard controller on the board).
I had to modify/make a new bios.boot file. I think they have one now that solves
this issue (never tried though).

What do you mean?

This makes sense. I assume that you built a new bios.boot by modifying the existing file? What did you change?
Any idea where I can find the .boot that solves this?
Thank you!

Simply use
[virtual=x86,bios_nokbd +compress] .bootstrap = {
instead of
[virtual=x86,bios +compress] .bootstrap = {