"File resides on different device"

Another thing I JUST noticed :slight_smile:

On my machine, I have a FAT32 partition. It only has an MP3 directory
(which is empty). Using fs-cifs, I mount the MP3 directory on my Windows
machine to /MP3.

I went to copy my files over to the QNX system. I went into
/fs/hd0-dos/MP3, and typed “cp -R /MP3/* .” (so it would recursively copy
all files in /MP3 into my FAT32 MP3 directory). It started spitting out
"cp: Skipping Directory "
“cp: (File resides on different device)”

What does that mean (never saw an error like that before)? I would like to
copy them over, any other things I could try to work around this?

Thanks,
Ron

Good morning,

Passing the -D option to cp will allow you to copy across device boundaries.

Cheers,
-Brian

+===============================+
Brian K. Hlady
OEM Support Rep
QNX Software Systems, Ltd.
bhlady@qnx.com
+===============================+
“Ron Cococcia” <stopspam@mingme.com> wrote in message
news:a3d2nm$9ff$1@inn.qnx.com

Another thing I JUST noticed > :slight_smile:

On my machine, I have a FAT32 partition. It only has an MP3 directory
(which is empty). Using fs-cifs, I mount the MP3 directory on my Windows
machine to /MP3.

I went to copy my files over to the QNX system. I went into
/fs/hd0-dos/MP3, and typed “cp -R /MP3/* .” (so it would recursively copy
all files in /MP3 into my FAT32 MP3 directory). It started spitting out
"cp: Skipping Directory "
“cp: (File resides on different device)”

What does that mean (never saw an error like that before)? I would like
to
copy them over, any other things I could try to work around this?

Thanks,
Ron

It was pointed out to that this behaviour isn’t POSIX. However, if you set
your POSIX_STRICT environment variable, then you needn’t specify -D to your
cp command.

export POSIX_STRICT=1

Cheers,
-Brian


+===============================+
Brian K. Hlady
OEM Support Rep
QNX Software Systems, Ltd.
bhlady@qnx.com
+===============================+
“Brian K. Hlady” <bhlady@qnx.com> wrote in message
news:a3e4ba$coj$1@nntp.qnx.com

Good morning,

Passing the -D option to cp will allow you to copy across device
boundaries.

Cheers,
-Brian

+===============================+
Brian K. Hlady
OEM Support Rep
QNX Software Systems, Ltd.
bhlady@qnx.com
+===============================+
“Ron Cococcia” <> stopspam@mingme.com> > wrote in message
news:a3d2nm$9ff$> 1@inn.qnx.com> …
Another thing I JUST noticed > :slight_smile:

On my machine, I have a FAT32 partition. It only has an MP3 directory
(which is empty). Using fs-cifs, I mount the MP3 directory on my
Windows
machine to /MP3.

I went to copy my files over to the QNX system. I went into
/fs/hd0-dos/MP3, and typed “cp -R /MP3/* .” (so it would recursively
copy
all files in /MP3 into my FAT32 MP3 directory). It started spitting out
"cp: Skipping Directory "
“cp: (File resides on different device)”

What does that mean (never saw an error like that before)? I would like
to
copy them over, any other things I could try to work around this?

Thanks,
Ron
\

Thanks Brian. I actually knew about the -D option, but I thought the
behaviour of cp without it was “interesting” since I’ve done the same thing
with QNX4. Thanks for the info!

-Ron

“Brian K. Hlady” <bhlady@qnx.com> wrote in message
news:a3efk1$ko6$1@nntp.qnx.com

It was pointed out to that this behaviour isn’t POSIX. However, if you set
your POSIX_STRICT environment variable, then you needn’t specify -D to
your
cp command.

export POSIX_STRICT=1

Cheers,
-Brian


+===============================+
Brian K. Hlady
OEM Support Rep
QNX Software Systems, Ltd.
bhlady@qnx.com
+===============================+
“Brian K. Hlady” <> bhlady@qnx.com> > wrote in message
news:a3e4ba$coj$> 1@nntp.qnx.com> …
Good morning,

Passing the -D option to cp will allow you to copy across device
boundaries.

Cheers,
-Brian

+===============================+
Brian K. Hlady
OEM Support Rep
QNX Software Systems, Ltd.
bhlady@qnx.com
+===============================+
“Ron Cococcia” <> stopspam@mingme.com> > wrote in message
news:a3d2nm$9ff$> 1@inn.qnx.com> …
Another thing I JUST noticed > :slight_smile:

On my machine, I have a FAT32 partition. It only has an MP3 directory
(which is empty). Using fs-cifs, I mount the MP3 directory on my
Windows
machine to /MP3.

I went to copy my files over to the QNX system. I went into
/fs/hd0-dos/MP3, and typed “cp -R /MP3/* .” (so it would recursively
copy
all files in /MP3 into my FAT32 MP3 directory). It started spitting
out
"cp: Skipping Directory "
“cp: (File resides on different device)”

What does that mean (never saw an error like that before)? I would
like
to
copy them over, any other things I could try to work around this?

Thanks,
Ron


\